Why can I not use an generic object variable in an "Actor" variable input

So I was passing an object variable to my HUD and it worked great. The HUD saw it and drew data to the screen based on the object. I then started adding stuff that changed the object, just added a few more actors it could become. Now It will not see the object variable, that is used before with no problems, as an actor so it will not use it. Here is a picture


I have no idea why it worked fine, then stopped working. I have no idea how it disconnected itself and then decided to no longer accept the variable. Did I find a bug or do something wrong? This is a variable passed through a Blueprint Interface. It is an actor on the level side but for some reason will not connect here.

Is this in your level BP? Where is the object at in terms of scope to the BP you are adding it in? What is this an object of? A class, an actor, . Also in your screen could you include the side menu that shows the variables - and select the one in question so it’s details are visible.

Here is a screen with all relevant information. The object in game is a static mesh, or a series of static meshes that i switch out for objectives
The place i am have the problem in is LN_HUD. I am giving it the data from Level Blueprint. from left to right:

  1. LN_HUD with variable selected and event that passes in data
  2. LN_HUD event graph where the original screenshot is
  3. The Interface that does the passing with the only function i am using at the moment
  4. Level blueprint where I am passing the variable (it is an objective

I’m trying to make sure I’m tracking here. So the Object from the beginning, what was it holding (Actor?). Then you started adding in more actors? Does that mean you are switching them out between uses, or are these being added to some object array? A the very top image it looks like it’s saying their are not the same (object.object → object.actor). Are you able to recreate the original working version that had only the one thing?

Blueprint nodes are refrences of real funtions in C++ APIs, there for blueprint is bounded to same rules as in C++. Set Actor Location funtion is part of Actor class, what you inputing is object in which thta funtion will be called and it needs to be actor, as object dont have that funtion.

So or cast your object to actor or set varable class to actor, if current objective is not actor… ten you cant use that object in set actor location, make it parent of actor or give him vector variable in which you can set location.