Why can I not modify Blueprint Components?


What type of Blueprint Class is it? Is the component that cannot move the Root of the Blueprint? I ask this because if a component is the Root then it cannot be moved. Can you show a screenshot of this? Any additional reproduction steps would be helpful in furthering out investigation.


I moved multiple objects into the blue print component tab and the move, rotate, and scale prompts do not show up. I have tried multiple objects (cone, chair, beam, wall, plane, box from inside component) and they have an orange outline. I can change their properties, but even if I change the transform properties they stay the same. Is there a setting I am missing? Any ideas?

I had created a new blueprint class, whatever that is called, and it was the root. That was the problem, everything else worked when I added them. Thanks for the help.

Using a Scene component as a Root is a good choice for a ‘dummy’ component if you want to offset things from it. As was mentioned above, you cannot move or scale the root component.