Why can I fly through walls in the Lightroom Demo on the Marketplace?

Why does my character “fly” through the room and walls, versus “walking” when I “play” the game and I’m not just in the editing tool?

Hi Nauiscaa88,

This demo is meant to be a lighting showcase for Architectural Visualization. Koola, the user who made the project, did not put a player controller in the scene to give you the walk around style nor did he use collision for his static meshes which is why you can “fly” through the walls.

Thank you!


Thanks Tim. It’s a real beauty. Props to Koola!

The architectural/environmental potentials of UE4 are really exciting.

Is there a simple way to edit the walls to add collision and a player controller, as you put it? Trying to use the showcase as an educational tool. Was looking at the “collision” tab and couldn’t quite intuitively figure it out…

No Problem! :slight_smile:

Adding the collision shouldn’t take too long, Especially since the objects are simple geometry.

Open the individual meshes you want collision on in the Mesh Viewer > Go to the “Collisions” drop down in the menu bar > “Add Box Simplified Collision”

The Box Simplified Collision should work for most objects. I would mostly focus on any mesh the player will bump into while walking around. Stuff like the window frame wont be an issue since the wall would have the collision. No since in wasting the time adding collision there.

To add the player controller so you can walk around you’ll want to create a new Blueprint of Character Class.

This will create a character that we can then add our input to so that we can have our character move around the world. This documentation may help as well although you wouldn’t need to use any of the animation stuff since I didn’t get the impression you want to add an animated character…

The inputs I used are taken from the First Person template using the sections:

  • Stick Input
  • Mouse Input
  • Movement Input

After copying these over to the Light Room Character BP that you’ve setup into the event graph you will need to go into Project Settings > Input > Axis Mappings and set them up the way they are in the First Person Template.

After that is done go to World Settings and under the “Game Mode” Tab change change the following:

GameMode Override: RenderToTexture_Game
Defautl Pawn Class: MyCharacter (This is the name of my character BP I set up)

Now when you play you should have everything setup so that you can walk around the level. You will want to make sure that you’ve done the collision first so that you don’t fall through the floor. :slight_smile:

If you have any questions or confusion about the setup feel free to ask.


Appreciate the detailed response! Helped a lot. :slight_smile: