Download

why C1083 error shows up even it was working fine...

I checked whether i put certain module in myProject.Build.cs file… I am sure I did.

It was working fine, but why on earth it said “C1083 no GeneratedFile.h” just now!

Error message : Severity Code Description Project File Line Suppression State
Error C1083 Cannot open include file: ‘NCFT_GameInstance.generated.h’: No such file or directory NoCountryForThem417 D:\NoCountryForThem\Programming\Unreal\NoCountryForThem417\NoCountryForThem417\Source\NoCountryForThem417\NCFT_GameInstance.h 11




#pragma once

#include "CoreMinimal.h"
#include "Engine/GameInstance.h"
#include "NCFT_EnumHeader.h"
#include "CharactersManager.h"
#include "EventsManager.h"
//#include "HUDsManager.h"
#include "NCFT_GameInstance.generated.h"

/**
 *
 */
UCLASS()
class NOCOUNTRYFORTHEM417_API UNCFT_GameInstance : public UGameInstance
{
    GENERATED_BODY()
public:
        UNCFT_GameInstance(const FObjectInitializer& ObjectInitializer);
    virtual void Init() override;
    UPROPERTY(EditAnywhere, BlueprintReadWrite, Category = "GameState")
        EGameStateEnum EGameState;
    //characters module
    UPROPERTY(EditAnywhere, BlueprintReadWrite, Category = "Characters Manager")
        class UCharactersManager* CharactersManager;
    //Events Module
    UPROPERTY(EditAnywhere, BlueprintReadWrite, Category = "Events Manager")
        class UEventsManager* EventsManager;


I think Unreal Engine hates me… Feeling depressed.

Close the error list window and look what is the actual error message from the compiler (in the log window). It’s probably something entirely different.

@Marjane: it seems we are getting the same error (I’ve opened a topic too) even though probably for different reasons, in my case I wanted to put my generic functions in a header I made and access them from all the classes from inside Blueprint, even though no idea if it is even feasable…

Anyway have you checked if you actually have this generated.h somehwere?
There is this link(below) where the answer explain how he forced it to created that .generated.h file, have you tried it?

you mean in Unreal Engine 4 Editor, it complies fine, but if it is in Visual Studio, how do i do that?

Open your Solution (in your project folder, the .sln file), click on Build->Rebuild Solution, but before that make sure you’ve opened the Output window
(Debug->Window->Output) and chose the Build tab, so you can see the output.
Also if you go under Tools->Options and then Projects and Solutions->**Build and Run , **from there you can crank up the verbosity of the Output, from Minimal all the way up to Diagnostic, though probably that is too much. Hope I’ve answered to the right thing xD

I tried Rebuild but failed. but it turns out that one of file included GameInstance carelessly. thank you for answer :slight_smile: