Why aren't the position edit boxes showing up for these SceneComponents?

I’m making a hockey game and I made a class called AStartingPositions to hold where the players, goal and puck are supposed to start (and so I can reset them easily). It just has a bunch of SceneComponents in it, which are defined like this:

USceneComponent* root;
USceneComponent* center;
USceneComponent* rightWing;
USceneComponent* leftWing;

In the constructor, they are instantiated like so:

root = CreateDefaultSubobject<USceneComponent>(TEXT("Root"));

center = CreateDefaultSubobject<USceneComponent>(TEXT("Center"));

rightWing = CreateDefaultSubobject<USceneComponent>(TEXT("Right Wing"));

leftWing = CreateDefaultSubobject<USceneComponent>(TEXT("Left Wing"));

I have the root SceneComponent as kind of a dummy because I want to be able to move them around in the editor and the RootComponent is trapped at the origin. I have another class that is set up in a similar way (it’s more than just SceneComponents) and in the editor it gives me edit boxes to type in the x/y/z coordinates for the position, but this one only gives me edit boxes for the scale. What dumb thing am I overlooking to get the position edit boxes to show up?

I’ve tried a variety of UPROPERTY settings, I tried adding a SceneComponent to the other class (it worked as expected), I tried using a different type of component as the root. If I add a SceneComponent in the editor, the position edit boxes show up for that component only. I’m out of ideas.