Why are UCX Collision Primitives Disappearing after Import?

When I import an fbx model from Maya with custom collision, the collision doesn’t work. The collision meshes disappear in the Engine, so it appears to recognize the prefix. But I can’t see them in the editor. The number of collision objects is said to be “0” too… I’m not sure what’s wrong.

5365-collision+error.jpg

I tested the UCX Collision way, too. It works for me, but I had only one “ucx mesh”. I named the “ucx mesh” like the mesh name.

In your case try UCX_sm_houseA, please let me know if this fixed your problem.

Oh I got it fixed I just needed to do an underscore before the number. UCX_sm_houseA_##

Actually there seemed to be a bug somewhere (could be Maya or UE4) because I couldn’t successfully add multiple new collision meshes without first importing the static mesh with 1 collision mesh as Headzup suggested. Once I imported with 1 collision working I could export the mesh with the other collision objects and reimporting worked. At least it works now.

Hey guys,

I’m having the exact same issue. Seems no matter how many UCX meshes I have, they won’t appear in UE4 after import. They disappear, but they just don’t create collision meshes. Super frustrating, have tried every variation on the format I can think of… always nothing! Any suggestions would be hugely appreciated! The asset I’m working with is a spiral stair case, so pretty much the most awkward thing! Ha.

Cheers!

Rob

I created collision primitive in Maya LT 2016 and exported it to UE 4.11.2. UE4 does not recognize it but in UE 4.9.2 it works fine. Is there any new way of creating a collision primitive in Maya for UE 4.11.2 or is this a bug in UE4?

I created a box ( SM_myBox )

I created a box that is slightly bigger than SM_myBox and named it as UCX_myBox. Deleted the history and selected both and exported as a fbx to both versions of UE4 ( 4.9.2 & 4.11.2 )
Works in UE 4.9.2 only

This is way too late, but I’m pretty sure the name of the collision mesh should be exactly the same as that of the static mesh, with “UCX_” as a prefix.

So in this case:
visible mesh = SM_myBox
collision mesh = UCX_SM_myBox

(This is how I do it with Blender and it works, in 4.12 at least.)

thank you.

Hello! I’m having this problem as well, but I am using Blender, and the naming does not appear to be the problem. Everything in the file is named according to the UCX_Meshname convention, but collisions are still disappearing. My mess consists of mulltiple meshes however and each mesh has it’s own appropriately named collision mesh. When I try to import each mesh individually, the collision imports as normal. But when I try to import them at once, the way I intended to, most of the collisions disappear. And it doesn’t make any sense why that would happen. I’m testing this using Ue4 4.11.2. Is there maybe some kind of bug that is preventing these collisions from showing up, much less functioning?

For multiple meshes, make sure that the collision geometry that you create does not overlap each other. Please refer to the UE4 DOCS