Download

Why Are My Walls Black?

Unreal Forum Group:

I am a beginner that’s super excited about UE4 and the promise of real time VR for architects and interior designers - amazing capabilities IMHO. I have lots of experience in 3ds Max and use it daily. I am doing some beginner’s tutorials and have a UE4 model that was developed in 3ds Max via FBX. I am assigning and creating my own materials (fun stuff) and have building walls that are an off-white material. I am setting up lights and building lighting solutions and see that my exterior walls remain a “dark blue/black” color, inside and out. First thought was that I had more than one object in the same place (yeah, I use VRay…) but found that I do not after checking my UE4 model. I also went back to the Max model that made the FBX for any inward looking faces, but there are none. Strange thing in UE4, when I move the exterior walls in the “up/z” direction a cm or so in the construction window, they turn the off-white material. When I do a lighting build, they return to their dark , almost black state. I’m stumped…

Sorry for the long post, but any help is greatly appreciated.
Being a newbie sucks, until it doesn’t!

Art / Seattle

Make sure that your meshes have lightmap UV’s set up:

Often times if the lightmap UV’s aren’t setup correctly they will turn up black due to overlapping or too small.

Make sure you have a second set of UV’s setup for lightmapping, and make sure the static mesh has the correct one of the UV sets selected for lightmapping.

Also, willing to bet this is a problem you’re having, make sure to add a lightmass importance volume around your level or whatever you’re trying to light with static lighting.

When you move static object in the editor, two things happen: 1) lighting breaks, and 2) preview lighting takes over, which is why your wall turns white and “looks correct”.

If you wanted to, you could set your object to be moveable, then it would use light probe samples instead (like a character). This would require a characer detail volume around the area in order for it to sample more light data from lightmass. This is of course just an option, but for what you need you probably just want to go with static lighting.

darthviper107:

Thanks for your reply…
Went back to Max model and applied UwrapUW and made sure no surfaces were overlapping.
Saved meshes/actors as editable polys and editable meshes.
Saved new FBX with same name.
Reimported to UE4 and updated actors.
Actors appear “correct” until lighting solution built.
See screen shot…

Actors turn dark and do not show correct material - still.

Help.

You check my recommendations?

Also, how are the normals on that object? Make sure all the walls, etc. are not set to the same smoothing groups.

Normals ok in Max model that generated the FBX.
Unwrap UVs made sure no surfaces are overlapping on channel 2 - UE4 lighting requirement as directed by my tutorial.
Reimported in UE4 from same new FBX.
Actors look “good” until lighting solution is built.
Actors still “dark” in appearance as before.
UGH.

do you have a lightmass importance volume setup?

Yes…my tutorial started with a first person template that included a lightmass importance volume.

See attached JPEG.

In this view, the light build solution has not been attempted yet, and the exterior walls are looking ok.
I expect them to get dark again once the lighting build is complete.

Art / Seattle

This could be the unknown knickknack:
LightmapChannel.jpg

Hirk:

Thanks for your reply, I appreciate it.
Tried your suggestion with each mesh that is dark.
Made the UV Channel change from 0 to 1, saved the construction window for each model.
Rebuilt the lighting solution, and it’s still reading dark.
Hmmm?

I’ll be glad when the solution is at hand…I feel like i will have learned something today!

Art / Seattle

I’m sorry, but I can’t think of anything else at the moment. Honestly I would have to look at your mesh to finally tell what is going on.

Sorry to intrude myself in this thread after a long time, but I’ve been having the same problem did you find a solution?

If using 3ds Max to build geometry try using the “reset xform” available in the utility tab. This will reset the object to it’s true state