Why are my shadows disappearing after baking?

I have these static meshes which appear to be rendering fine with the default light and sky, however, after I bake them, the shadows lose much of there form leaving behind only part of the shadow.

The shadows appear fine on the structure to the right of these meshes. They are all static.The light source (default, intensity lowered) is stationary.


Thanks for any help, I have attempted for hours now to correct this with no luck.

Try increasing the lightmap resolution of your landscape (terrain).

BTW, this is a great reference for troubleshooting lights/shadows related issues:

Thank you Marco! I had actually used that guide extensively to remove modular seams from my map so that is embarrassing.

I was able to fix my problem by increase “Static Lighting Resolution” from 1 to 4 in the landscapes details.

I could not find a specific setting to change lightmap resolution like you can with static mesh. Was “Static lighting resolution” the correct property to change? (It looks good, just wondering from performance perspective).

Yes, that is the right property to change. There is for sure a small hit on performances, but since the shadows are baked into the lightmap of of the terrain, it is not that dramatic. It is more memory usage. If you would use dynamic lights then that would definitely make a difference.

If you are curious, you can use UE4’s profiler to check for performances with lowres shadows and highres shadows, then compare them.