Why are maps not being packaged?

I have made a menu for my game that uses the ‘Open Level’ node that goes to various mini-games.
This works in the editor, but when I package and launch my game on Android or iOS the menu buttons don’t work.
When running the ‘stat levels’ command only the Default Game Map shows up. The other maps aren’t there.

This seems like it may be a 4.3 bug. Even Swing Ninja in 4.3 shows the same results when packaging as well.

Could you post how did you setup your packaging in UnrealFrontend?


These are my packaging settings currently, although I’ve tried every other combination.

What I refer to is using the UnrealFrontend to cook all our maps, by default it only cooks the default map, you can either change your ini settings to alwasy cook certain maps or use UnrealFrontend to select which maps to cook.

Just open UnrealFrontend and go to the ‘Game Launcher’ tab (the others could be also ok, this one just has the full path) and then the Advanced section. From there you specify how to build, cook, package and launch your game. In the cooking section you then select the maps you would like to cook apart from the default map.

This is an example of how to package an HTML5 build (similar on every platform): Html5 build issue - Platform & Builds - Unreal Engine Forums

Here is the documentation for Unreal Frontend as well.

Thanks a lot! This helped a ton

I think you have to re-accept the answer :smiley: Strange system :smiley:

@Explosivo. Did you manage to get “open level” to work in packaged game?
Choosing levels in Frontend is not doing it for my game. As in your case all works fine in the editor.