Why am I unable to launch my project following 4.0.2 update?

Hi, I have been working through the First Person Shooter (Tutorial) and was going to try to finish it tonight, however when I got home from work, and updated the engine to 4.0.2 I can no longer open my project. I got to the adding projectiles and shooting section step 5 following compilation and am unable to proceed due to not being able to launch the editor successfully. I have been able to successfully open the editor following the update with the “shooter game” provided content.

Attached is the most recent log file in my project and DxDiag settings.

Could someone please help me with this?




-I have also tried rebuilding my solution in VSE. It builds with no errors, but the editor still fails to launch my project.

-The crash log (pending-reports.json) in C:\Users\XXXXX\AppData\Local\UnrealEngine\4.0\crash-reports only contains

	"crash-reports": []

I get the same error message as the question here.

Hi ra_ar,

I just want to make sure I am absolutely clear on something first:

  • You are able to launch the editor, and sample/new projects without issue?
  • You are not able to launch your own code project without crashing?

Is that correct?

Stephen, that is correct.

edit: To clarify, I have created a new project. I can launch this project successfully after closing the editor & launcher, and then re-opening. I cannot launch the project I was working on in Unreal Engine 4.0.1, the details of which are listed in the opening question.

My primary concern here is that I’d like to know what is causing this so I can ensure to take action to avoid this from happening in the coming engine patches and having to potentially redo the work each time.

After an hour or so I got to the same place in this new project that was started using version 4.0.2 and am experiencing the same problem of not being able to launch the editor at that exact same step.

Hi ra_ar,

That is interesting, but a slight relief that the issue is unlikely to have been caused by the engine update.

While in VS, if you select your project and choose to Start New Instance are you still experiencing the issue when the project loads? Is VS able to provide any better debugging information?

The project acts like it tries to load, unreal editor displays a loading screen, then an exception occurs.

Since I am pretty new to all this I am not entirely sure how to interpret the exception error. Attached is some information I copied from VSE when I did the debug → Start New Instance operation. If there is a better way I can provide this information, or any additional information needed please let me know. Thank you for all the assistance so far.ExceptionInfo.pdf

We apologize that we were not able to resolve this post at the time it was created. We have since improved our systems and workflows to provide better coverage going forward. Many changes have occurred to the Unreal Engine since this post was made, so we are marking this as Resolved for tracking purposes. If you still require assistance with this issue, please let us know. If the issue has changed in any way, we recommend you create a new post.

Thank you.