Why am I seeing visual glitches on mac in 4.4?

I have seen a few post talking about this visual glitches (white flickerings) on mac but they talk about being something that happens in certain modes of unreal… i get these all the time, in the preview of 4.4 it was way worse than in the 4.4 release but i still get them all the time… does anybody has a solution for this? or can give an explanation?
i have been searching for this and nothing comes out… is it just me? or is a laptop thing?

i use a 2.9GHz intel core i7, 8gb, 16MHz ddr3 OSX 10.9.4 (laptop)


I’m not sure what you mean by white flickering, could you provide a more detailed explanation?
Also could you provide the system profile & engine logs? System Information.app can generate a system profile & the Unreal logs are found in ~/Library/Logs/Unreal Engine/


I just tried to record it… but the glitch doesn’t seem to appear on the recording… i would say that it looks like a few white lines or squares that appears the screen in a horizontal manner for just a moment…

as for the logs and system information…

thanks for the help

I bet if you do a screen recording using Quicktime & the problem manifests then it will be in the resulting movie. You might have to use the left/right arrow keys to step through the movie frame-by-frame to see them though.

for some reason it doesn’t appear in quicktime or any other screen recorder i tried…i just added a phone video… i hope it helps

those lines also appear when a youtube video is playing on fullscreen and unreal 4 in running…

I’ve not been able to reproduce this on the machines I have to hand here. If they aren’t visible in a Quicktime screen recording but are in a video of the screen via a camera, then the problem is occurring beneath UE4. We render to a buffer & the OS is then responsible for blitting that to the screen. The corruption is being introduced somewhere in that process. I’m not sure how to address this.

I’ve now seen this on my own MBP when forcing the use of the Intel GPU to run ElementalDemo, looks like a problem during the blit to the screen which is controlled by the OS.

This has been added to our bug database as [UE-6124] - it appears that there’s some sort of race condition/conflict between UE4’s blit to the screen and some types of video playback on OS X when using the Intel HD 4000 GPU, with possibly other Intel GPUs affected.