Why am I seeing an error with the K2Node_Event_Other and what does it mean?

So I am getting this error every time that I run my game. It seems to occur whenever I shoot my own bullet or bombs, and whenever the enemies shoot bullets and I have no idea why it is happening, everything seems to be working fine. But I don’t know what this error means; it is the same for all scripts that I am using for projectiles.

ANY HELP is much appreciated. It may be important to note that I created a copy of BP_EnemyBullet to create this blueprint; however the error occurred on EnemyBullet before that.

Here is a video of what happens in my game: [SideShooter_Error Messages - YouTube][1]

And here are the blueprints/error message I am using/getting (Check comments for others):

[http://i61.tinypic.com/97r60i.jpg][4] - Bomb Event Graph

[http://i62.tinypic.com/205p7k9.jpg][5] - How Bombs (And my other projectile) are spawned.

If you need any more information then feel free to ask.

K2Node is C++ class representing node in this case a event node

Hi Tom D,

This is a rare error that we have experienced internally as well and are currently looking into.

As a workaround, go into the EventGraph and the Construction Script of both the BP_EnemyBullet and the Bomb_BP. Disconnect all of the nodes, compile, then reconnect them, and compile again.

Sometimes this will fix the issue. Please post back and let us know.

Hi TJ, thanks for the response.

I did as you suggested and am still getting the same error message. If it helps at all on my system it is Bomb_BP.Bomb_BP.UserConstructionNode.K2Node_FunctionEntry_97 that is continually popping up. (I have no idea what that means, but you might).

What is odd however is that I have two types of enemy bullets:

Exact same blueprints but the cube bullet is scaled up and has different damage; no error message for the CubeBullet_BP so I’m going to go through everything (Defaults, components, etc.) and look for differences.

And the player bullet (The fast shooting one) is pretty much the same blueprint as the Bomb_BP but doesn’t produce errors either.

Hmm, another idea is to recreate the blueprints in question then delete the old versions. I know that’s not an ideal workaround but since it’s showing the error is coming from an empty Construction Script it’s very odd.

If that doesn’t work, could you post a higher res screenshot of the above ‘How Bombs are spawned’ pic?

Was there any real resolution to this problem? I am running into the same thing on version 4.6.

Hi ronsoule,

This is still an issue that we are investigating. Generally these errors will not effect the performance of your game but they can be quite annoying.

There is another possible workaround if you are seeing these errors in a blueprint that is ‘not’ empty. You can try adding an ‘Is Valid?’ node to check actors that you are referencing. If this is the case, please feel free to post some screenshots and we will try to help you troubleshoot the issue.

Thank you I will give it a try and let you know if it works. Your help is appreciated.


So the “is valid” node says that when a hit event occurs that everything is all right. But when I try to destroy the actor with the node “Destroy actor” i get the I get the message “It is pending kill. property:'K2Node…”

The actor does get destroyed but the error/warning still occurs.

Thanks for the help,

So im adding more events to my Enemy blueprint. I am using the Event Hit node with actor has tag node and branch. To check if the hit of collision of the bullet is with the enemy but it seems to fail and not print a string.

So I guess no update to my questions? :slight_smile:

If the IsValid? node doesn’t fix the issue, then you could try disconnecting all of the wires in the blueprint > compiling > then reconnecting the nodes and recompiling. This will sometimes solve the issue.

The next step would be to delete the blueprint and recreate it entirely.

Unfortunately we won’t have a concrete solution until this issue is thoroughly investigated by the developers.

As far as the hit collision issue, any screenshots that you could provide would be appreciated.

Hi Tom D & ronsoule,

We have this issue logged as JIRA UE-3412 in our tracking software. Our developers are will be investigating it further and we will post back here with updates.




Hi skkhan,

This was marked as ‘Won’t fix’ because it was about 3 years old and reports of this error had subsided. If you are still experiencing this issue in the latest release (4.17) could you post a new AnswerHub report and include repro steps and/or a small test project?

its easy just fix that: destroycomponent mesh of the projectile no to all you need colisionbox or your script will fail