Why am i getting this red lines?

How can i get rid of them?

It would be of help if you could describe your problem some more, if you are getting a line from your camera into the “game world” you are most likely seeing ray-traces, if so you need to find the “Line Trace” node and turn off the debug type.

f657bf0d0bea4c9f05ae8859d639cab10907c94b.jpeg this is the problem

f657bf0d0bea4c9f05ae8859d639cab10907c94b.jpeg this is the problem, thanks

I’ve seen this as well. From what I can tell, it gets longer and longer the further the object is away from world origin (0,0,0)

Not sure what purpose it serves though.

Do you know how to get rid of them?

Hmm, seems like you have pressed a shortcut, because normally those red lines are pretty small :slight_smile:

Go into the editor preferences and reset everything to default. Probably it will solve your problem