Why am i getting long freezes when moving BSP?

When i move geometry in the engine it freezes for around 2 minutes. Clicking undo freezes it for around 5 minutes. I’ve gone into settings and unticked “update BSP automatically” however this forces me to rebuild geometry every time just to see how it looks. Its the most frustrating thing about the editor (other than random holes) and although it works fine with that option unticked, i’d like to know when and how a permanent fix will become available. There are no problems with static meshes at all, it just seems to be BSP. I have been able to recreate the effects by starting a new default level in the unreal tournament build (all builds) and adding several bsp brushes, then using the geometry editing section to manipulate them by moving the vertices or faces etc…the pauses start out slowly and the more times you edit/more brushes you add, the longer the delay becomes. I have started a new map and placed and edited a total of 12 brushes, none of them particularly large, and the pauses have already begun. It’s around 5-10 seconds now however on my last map, which contained over 200 brushes, the length of freezes were ridiculous. Hope this can be solved for good and would be extremely happy if anyone could help. Thanks.

1 Like

Hi SopranoObject,

Thank you for your report. The problem of slow build times is a known issue with BSPs. Our developers are working towards a solution for this, it is an important issue to us. The best known work-arounds are the techniques you have described; turning off “update BSP automatically” and replacing BSPs with meshes as you build your level. Sorry for any inconvenience that this has caused you.

-Alexander

Looks like it wasn’t important enough for it never got fixed… I’m getting some pretty annoying rebuilding freezes every time I move or duplicate a BSP cube.

Same here, still getting this issue. Incredibly annoying and really slowing down my workflow.

I get the same problem and now the time get between 10 second to 40 second. the problem is ridiculous knowing that i have less then 200 BSP.

And 4 years later, still no fix.

Hello, Willard720. I think I am getting the same problem as you, and since the entire screen on Unreal freezes, I have to restart the entire computer each time to fix it, but after reading over, I think those screens are created when there is some sort of hole in your BSP, so maybe moving the brush might fix it. I haven’t tried it, but it seems reasonable.

Hello, Willard720. I think I am getting the same problem as you, and since the entire screen on Unreal freezes, I have to restart the entire computer each time to fix it, but after reading over, I think those screens are created when there is some sort of hole in your BSP, so maybe moving the brush might fix it. I haven’t tried it, but it seems reasonable.

Same issue to me. It was caused by this giant blocking volume I was using as a Sketch for rebuild the entire level with static meshes. Removing the volume now it’s calculating at normal speed. So if you have this issue, try to work in a temporary level without strange volumes on scene, or bake to static mesh as many geometries as possible.
You can also make a copy of the level, remove a part of the geometries to work faster, and then copy paste to the “original” level. There are many workarounds.

I recently installed using UE5 and opened a level I created in UE4. Now, whenever I try to move, scale, or rotate any BSP object the editor freezes for 20-30 seconds. Static Meshes seem to work fine. I can fix the issue (somewhat) by creating sublevels and attaching the BSPs to them in small groups but it’s not an ideal workflow especially when trying to work quickly through a blockout.

This problem didn’t exist in the latest rev of UE4 and only surfaced when I migrated to UE5. Is there a setting I’m missing?