Why actor doesn't appear after runtime spawn by remote control?

Hi there,

I have a very strange issue with runtime spawning actors. This newly generated object doesn’t appear. I have an Actor with a function for generating (spawn) another actor:

  1. When I run this function in EditMode, I get the result as expected.
  2. If I try to execute this function via RemoteControl in EditMode, I don’t see the new object until I move the mouse over the render window. It seems ok, but:
  3. When I run the GameMode and send the remote command, I don’t see the new object. But, at the same time, I see the debug message from the PrintString (see on the right side of the screenshot). Funny thing, this object appears after I push the Esc button (go to the EditMode).

This is how it works in EditMode:


And, how it works in the PlayMode:

I’ve found that the path of the map is changing between Edit and Play modes.
In Play mode I have to add a prefix UEDPIE_0_ to the map scene.

For example:

Edit mode:
Play mode: