Download

White flashes when objects appear in line of sight.

Hello!

When I around to the level I keep seeing white, bright flashes. It seems like the meshes take a second to load in when they appear in line of sight. What causes this? Culling? How can I fix it?

Added video showing the phenomenaena

vlcsnap-2015-02-18-14h59m58s102.png
vlcsnap-2015-02-18-14h59m47s12.png
vlcsnap-2015-02-18-14h59m16s126.png

I have seen this before, but I forgot how I solved it… :frowning:

-do they just appear at certain positions/meshes
-do you have a light which shines from the back of the mesh
-which engine version do you use
-how does it look like in “action”? -> just some very short flashes or longer ones
-make sure to use the “epic” quality settings

I use version 4.6.1 of unreal.
The flickering is everywhere when the player moves, especially at high speed.
Short flashes, they disappear as soon as you focus on them or stop moving.
epic setting was on.

Worth mentioning that the entire level is made from BSP’s converted into static meshes.

Here is a gif showing the thing - forgot to add a video.

hsrzg.gif

Do you have a bright background there somewhere in the level? Cause it seems like occlusion culling issure for me. Meshes appear a bit too late thus you can see the background for a short time then the mesh pops out when the engine realises it should be visible now.
Try adjusting the mesh bounds maybe.

I found a solution of sorts. In project settings, I turned of occlusion culling. This does not feel lika good solution. Is there a way to get Unreal 4 to stop being so sensitive in what it culls? The three settings bellow occlusion culling did nothing useful that I could detect.

Maybe check the meshes, see if the bounding volumes look correct - if the bounding box was way off from the actual geometry, that could possibly cause the meshes to be culled inappropriately

I have been fighting this issue for some time now. I am randomly building levels by spawning rooms and I would get white flashes everywhere. Managed to improve the situation a lot by having all meshes of a room use a single bounding box as the root of the actor. Another benefit from doing this is that performance improved a bit as well.

I don’t think it’s the bounding boxes being being off though as they look correct on all my meshes. When the bounding box is off the behavior is more consistent and you can find spots where you can see through when standing still. What me and StraitCurrent is seeing is flashes that can only be seen as you move around and they only appear for a few frames at most.

From reading some more posts on the forum and answer hub the dynamic occlusion culling is based on the depth buffer from the previous frame which means there isn’t much that can be done to get rid of it completely other than disabling occlusion culling as you did.

I will try to extend the bounding box of my rooms a bit so they overlap and hopefully that will get rid of most of it. Currently it mostly shows up when I open a fast moving door but if the rooms bounding box extends through the door the occlusion should already fail even when the door is closed.

I’m Having this as well, any good news?

Is this a help?