While Texturing "Processing failed: The application has run out of memory"

I got the error “Processing failed: The application has run out of memory [0x4002\0x4001\0x7\0x7]” while texturing. I was using the following settings, from the UV generation on my model

My machine has 128 GB RAM, Virtual memory on a dedicated Optain 50GB-178GB, and a System Managed Thunderbolt 12 drive RAID that has 103 TB open! I can’t understand how this can run out of memory with this much fast virtual memory available. Is the error wrong?

Hi greg,

did you do a search of the forum yet?

I think I remember some bug report about very large numbers of texture files, which I would say is the case with 660.

Thanks Gotz, yes, I have read half a dozen posts on this. Not sure if this is the one you are referring to https://support.capturingreality.com/hc/en-us/articles/115001483771-Huge-scene-reconstruction many of the posts reference it but the site says “oops unavailable.”

I still think that the software should continue to calculate whether it is using real RAM or Virtual Memory. I don’t think it ran out of virtual memory because in addition to having massive resources it wasn’t even using what was available when I checked on it while processing. 

It would be nice if this is a limitation, if we could get a formula that would let you calculate how much memory you will need to complete a given number of textures to avoid wasting time on very long processes that won’t finish. I can even imagine software checking to see if you have the resources required to complete a task before starting.

My next attempt is going to be to reduce the number of tiles by shrinking the gutter, then adding the gutter back in a Texture Reprojection. Hopefully RC doesn’t have the “glittering gutters” problem in the reprojection that many realtime engines mipmapping have.

Hi greg,

I thought you might have - just checking…   :slight_smile:

I’m with you on all of your suggestions and you’re not the first one to voice them.

It really seems like it should be possible to have such an estimation.

That’s weird that this post isn’t available. Maybe an error?

Have you tried getting in touch with support directly?

Thanks Gotz,

In case anyone else is in the same situation in the future. The approach I took worked, apparently texture reprojection does not have the memory requirement that generating the texture from the images does and the size of the gutter has a significant impact on the amount of RAM required so running those separately helped.

Although I was able to get my project done it still worries me that RC wasn’t able to use the virtual memory. I hate to think that this is the upper limit of what can be achieved.

1 Like


I can now think of 3 reasons why you are getting the message above at this forum:

  1. it is located in the section ‘Report a Bug’ and you got signed out from the webpage (sometimes it happens without your “intervention”),

  2. or the post has been marked as spam (and it is currently in the spam folder of this forum, which is private),

  3. or it is an article that has been removed (and highly likely replaced by an updated version).

Thanks Lucia, well if it is in another article I have probably already read it from the searches I did.

Thank you for the tip about the gutter - its the only thing that worked for me! Not sure how it relates, but with about 20 pixels it went through. Noticed that it textures with way less cameras with bigger gutter during processing steps visible in the console (ex 1500 cameras (2pix gutter) vs 350 camers (20pix gutter).

Been banging my head with out of memory and stage 01: sanity check error for almost a week on one particullary large interior model with 8500 cameras. It created 200 gb of cache during each texturing run. My setup is 256 GB ram, TRX 40, 4090+3090 and made a 350 gb page file for this project- still was getting out of memory errors.

In my case, I had to retexture to a clean mesh I made in Maya. Did this succesfully multiple times before with no problems on other projects, but not this time. Once waited 15 hours of texturing just for it to say Out of memory on 75%. Definetly +1 on some way to predict if it will fail.

Some additional tips which might have contributed to a succesful texturing in the end for me:
*Added Reconstruction Region on imported model - noticed much faster preprocessing times
*Used Optimize points function in zbrush on a clean model before importing to RC
*Rechecked non-manifold geometry