Which program to associate a uproject with?

I’ve recently added a new SSD to my Windows PC and installed Windows 7 & UE4 to it but it seems that the way in which I’ve migrated the engine and my projects to it have caused a problem.

Basically, if I try to open any project from the launcher or from Windows Explorer I get the error " file does not have a program associated with it for performing action…".

The Launcher would usually identify pre-existing projects when it’s installed for the first time, but I installed the Launcher and Engine prior to grabbing the latest of my projects from Perforce.

Now I know that uprojects are generally opened with ‘Unreal Engine’, at least according to the Windows ‘Open With’ window that was on the previous install. However, no such program exists within the Engine folder, just UE4Editor & UE4Game.

And unfortunately when you uninstall the Launcher, you are still left with alot of files, data and register entries associated with the hidden folder ProgramData/Epic… so I don’t know how to get a clean Launcher again without formatting my SSD and starting over.

Does anyone know how to associated .uproject files with the program Unreal Engine?

1 Like

When I did , it lost the file association context menu. So when I’d right-click a .uproject file to say, “Generate Visual Studio Files” that choice is gone now. A new installer download doesn’t give me a choice to Repair these sorts of things either, it just gives me a choice to Remove an installation of the engine.

What’s the best way to restore the context menu for .uproject files? Thanks =)

When I uninstalled 4.13.2 from the launcher it screwed up the file associations. The context menu for .uproject files stopped working. No solution I found online fixed it. Uninstalling and reinstalling everything did not fix it. Running Setup.bat in my source-based build (4.13.1) failed to fix it as well.

I had to go into Regedt32, search for “Unreal”, and delete everything I thought was safe to delete. I was very mindful as I did , so be careful before you delete anything. I backed up the entire registry first and I didn’t touch anything that wasn’t obviously something Epic added – like VS2015 had a recent projects list that showed up. Stuff like that I didn’t mess with.

After that, reinstalling the launcher and 4.13.2 still didn’t fix the problem. But when I went into my source-based build and ran Setup.bat, it asked me if I wanted to set up file associations. You know what my answer was.

Then it took a reboot to get the file associations back. Context menu and all! I can now see both the launcher-based “4.13” and my source-based build in the “switch version” drop-down.

Epic: Please consider addressing . And no, I’ve been through enough and I need to get back to work so I can’t submit a bug myself.

Associating the files in windows allows you to double click to open them but you do not get the Right click context menu options like building visual studio files etc. I didn’t realize that with my previous guide. Here’s a quick tutorial video on the proper fix.


I have same problem but how can it be solved currently in windows 10 professional? I have unreal engine 4.18.3

Run Engine/Binaries/Win64/UnrealVersionSelector-Win64-Shipping.exe

Sorry, my previous guide did NOT actually fix the. I’ve updated the post with the proper fix.

Thank you, thank you, thank you TorQueMoD!! Doing what you recommend in the video fixed the problem for me on Windows 10 - aaaaand saved my day! :slight_smile:

Thank-you for the solution

was exactly what I needed! Thank you! You’d think it wouldn’t be hard for the launcher to automatically do whenever you install a new version of the engine, or at LEAST when you install your first version … but the first post here was over six years ago now and it’s apparently still a hassle for newcomers. :frowning_face:

1 Like

Thanks a lot! It really helps!