Download

Which Linux IDE works the best with Unreal?

I tried KDevelop and Codelite, and it seems like both projects aren’t under development anymore. Currently, I’m using Qt Creator so far that works the best. The only, issue I’ve found with Qt Creator is the intellisense doesn’t always work. Personally, I usually use CLion and would love to see support for that built in. In the mean time which IDE works the best with Unreal?

What does not work with codelite? QtCreator the best? If code completion does not work what does work?

How about vim?
Also, have you tried Visual Studio Code?

I actually got codelite working correctly. I think I must have skipped over actually trying it. For QtCreator it just worked for me without needing to configure anything on its end. Qt did have some issues with spaces in file paths. But, I got codelite working, and code completion works correctly. Still wish CLion was supported. Does anyone know what’s needed for improved cmake support in Unreal? I noticed there are some pull requests for improving cmake support, that have been sitting in limbo for months. Considering Jetbrains has a fast debugger with the new release I’d love to got back to the IDE i’m most familiar with.

I actually spoke too soon. CodeLite does a great job with tab completion, but seems to be having issues with compilation. I noticed the plugin lists versions 7 / 8 in the name. Arch just has 9 available in the repos might that be why compilation isn’t working?

I followed all of the steps in your video. The only errors I’m getting when trying to compile are about not being able to find Unreal classes.

Compilation has nothing to do with Visual Studio, XCode, CodeLite, KDevelop, QTCreator or what so ever. Those are only shells which calls scripts that is using UnrealBuildTool.exe. So your compilation issue is from something else. The plugin version shouldn’t matter because the plugin (and all the other Accessor plugins) are opening files withing the selected IDE.

I primarily use CLion when developing for UE4, but as you say CMake has been a little lacking for a long while. I’ve submitted a PR that integrates the old changes, and fixes a number of other issues with the CMake generator. The patch is for just one file that hasn’t been touched in months, so if you want to try that out you should be able to integrate the changes into the latest branch without a hitch. There’s a full summary on GitHub (https://github.com/EpicGames/UnrealEngine/pull/2516), but it’s basically code completion, proper build targets and way faster file generation.

If you get issues here and there with macros, be sure to switch CLion over to use Clang instead of GCC. It changes a bit of the semantic parsing, which makes things easier: http://stackoverflow.com/a/35493034

I like CLion more but I’d stick with Visual Studio Code for linux.

Is there no need for a CLion source code accessor?

CLion uses CMake files which UBT generates.

I would just prefer to be able to open it from the editor if possible.

Which Linux IDE works the best with Unreal?
I use QTCreator for 5 years now. Intellisense is quicker than Visual Studio i heard. Integration with QT windows is good although a mess if you try to combine it with unreal.
I would stick with QTCreator if someone would write a linux tutorial how to load my uproject properly an bypass the “argument to long” errors.

1 Like

I just use vim for code editing and the make command to compile my project when I’m not in the editor.

1 Like

Hi, I just started to learn UE and recently came across the same question. In Windows, if we double click the script in UE, it will open directly in Visual Studio. I’m the same as OP, on Linux as well (Ubuntu). You mentioned vim, how do I modify / write my class from UE and open it directly with terminal (vim) ? Actually I’m not familiar with IDE and have always been coding with vim. It’d be perfect if I could just do it with vim, but I don’t know how.

Just switch to Windows and use Visual Studio. All Vulkan-based Linux versions after 4.25 - last one that had an OpenGL mode - are pure disaster. 4.26, 4.27 and surely 5.0 crashes randomly on mouse moves, widget interactions and so on.