Download

Where is Set Scalar Parameter Value?

Hi, I’m a newbie, and I’m learning now. Just studiying about Material Parameter Collections in this documentation page:

When I reach the part of blueprints, I need 4 nodes to follow the example. I have 3 ones, but I can’t find “Set Scalar Parameter Value” node.

Where it is!?. Or in 4.7 has been changed to other name?

If you drag off the ref pin of the make dynamic material node and start typing scalar it should show up.

The only “dynamic material” node I can see in level blueprint is “Get Dynamic Material”. I can’t see “Make dynamic material” anywhere…

What’s going on?

Ive just reread that you’re using a material parameter collection rather than a dynamic material instance. Regardless, I think your problem is that you’re using the level blueprint rather than an actor blueprint - there are some commands not exposed to certain blueprint types

It’s odd. In the documentation page, I can see this image:

https://docs.unrealengine.com/latest/images/Engine/Rendering/Materials/ParameterCollections/MPC_Added_Nodes_To_BP.jpg

Where I see clearly “Level Blueprint” and the “Set Scalar Parameter Value”.

I don’t understand then how to continue with this. Anyway, thanks for your time, Dannington.

Someone have any ideas?.

make sure you drag off the “set dynamic material” node for it

I had the same problem, but solved it in case you are still interested.

For anyone suggesting to use the dynamic material nodes; dragging it off any material source just seems to lock the node into being for that material only; it won’t actually give us the option to select the parameter collection instead of the material.

The solution is rather easy however. It feels kinda wonky, but I tested it and it works without any errors or warnings.

What you do is place the node anywhere where it is available per default, such as in an object blueprint or something. Copy the node with CTRL-C and then paste the node into the level blueprint. If it doesn’t work the first time, just try again; with my machine I have the problem that sometimes the blueprint editor doesn’t seem to register the CTRL-C command. Anyway, doing it that way enables you to use the “set scalar parameter” node in the level blueprint as well. I reckon it’s a bug or something, since the page you linked to obviously suggested you could just place the node without having to be creative about the method.

Or perhaps just try turning off context sensitive when you go to add a new node?