Whenever I open epic games launcher it open Crash Reporter

It is really ■■■■■■■ me off that whenever I open epicgameslauncher.exe It pops up with this message:

here is the log file: [link text][2]

PLEASE HELP!!! I’VE RESEARCHED AND RESEARCHED, but NOTHING!!!

Here is my pc specs:
Windows 10 home
Intel Corei5-4570T cpu @ 2.90GHz
RAM 16 GB
64bit, x64 based processor

And I’m running 64-bit, and I noticed that I didn’t have any Win64 files installed but epic games installed in Program Files(x86)

I right clicked epic games on my desktop, properties. Then at the end of the shortcut I typed in -OpenGL. That helped a bit but when it got to the end of the update it came up with the same screen.

well i finally fixed it. Right click desktop, NVIDIA Control Panel. Click on 3-D settings on the left. Program settings, add program, select epic games launcher. Then there should be a dropdown option thing that says “Use global settings”. Click on it and select Integrated graphics! Click Apply. Exit. Refresh desktop. Open epic games launcher.For me i’m pretty sure it showed a black window but don’t worry. Have some patience. Your welcome

nah man still not working