Download

When you create a project in C++ gives an error.

Hi all. When you create a project in C++ displays an error.


The project failed to compile with this version of the engine. Build output is as follows:

Running D:/Unreal Engine 4/4.7/Engine/Binaries/DotNET/UnrealBuildTool.exe MyProject Development Win64 -project=“C:/Users/Вова/Documents/Unreal Projects/MyProject/MyProject.uproject” -rocket -editorrecompile -progress
Parsing headers for MyProjectEditor
Reflection code generated for MyProjectEditor
Performing 10 actions (1 in parallel)
PCH.MyProject.MyProject.h.cpp
D:\Unreal Engine 4\4.7\Engine\Source\Runtime\Core\Public\HAL\PlatformIncludes.h(5) : fatal error C1083: Cannot open include file: ‘new’: No such file or directory
[2/10] Resource ModuleVersionResource.rc.inl
D:\Unreal Engine 4\4.7\Engine\Source\Runtime\Core\Resources\Windows\ModuleVersionResource.rc.inl(3) : fatal error RC1015: cannot open include file ‘windows.h’.

[3/10] Resource MyProject.rc
C:\Users@progress ‘Compiling C++ source code…’ 82%
-------- End Detailed Actions Stats -----------------------------------------------------------
ERROR: UBT ERROR: Failed to produce item: C:\Users???\Documents\Unreal Projects\MyProject\Binaries\Win64\UE4Editor-MyProject.dll
Cumulative action seconds (2 processors): 0,00 building projects, 0,97 compiling, 0,00 creating app bundles, 0,00 generating debug info, 0,00 linking, 0,00 other
UBT execution time: 20,45 seconds


From all this I realized that the error is likely due to the lack of some library.

Do you have the Windows SDK installed? If you already have it, you may need to add it to your system paths.

Directx SDK?

I have this file for example here:

C:\Program Files (x86)\Microsoft SDKs\Windows\v7.1A\Include

edit: To answer your question, I guess it’s called Microsoft Windows SDK.

The SDK I installed. And the error remained.

Are you sure, that the path to your Windows.h is in your system variables?

You should have a system variable which is called “INCLUDE”, which should include “C:\Program Files (x86)\Microsoft SDKs\Windows\v7.1A\Include” and more.

Where exactly is this way possible to register?

I’ll make a video as this error occurs.

Just search in windows for “Environment Variable”. But please be careful, do not delete any existing path. There you should find a variable called “Include”. The value of this variable should include the path to your SDK Include folder. Only if this path is set Visual Studio can find your Windows.h.

You incorrectly have understood my problem.
Here’s a look at this video: https://youtu.be/4tCIL-6bBBQ

in the error message you can clearly see that Unreal Build Tool (UBT) has problem with your user name, because it contains special characters (seems to be Russian), similarly to my user name (Iván)

  1. do not place you project under your user name, VS won’t compile too.
  2. you use an old version 4.7.2. I personally started a thread on Answerhub and took part in fixing this issue when 4.7 was the actual version, because it totally prevented Hot Reload to work, even if the project was e.g. at C:\UE\TestProject, because UBT during Hot Reload put some temporary stuff under user folders. Finally it was fixed around 4.7.5 or later, the last 4.7 edition or 4.8 are definitely good, you can search release notes or my thread on Anwerhub.

Good luck :slight_smile:

As I understand it the user name must be in English. In any which case, thanks, I will try to do something.

yes, if you want to place a project into the user folder or its subfolders.
and to get hot reload work, you need a newer engine version.

I am facing the similar problem too , Please let me know the method you followed to solve the problem

thank you.

Try to compile the project using Visual Studio Express 2013 or Visual Studio 2015 (depending on engine version). I just have the no versions of Visual Studio.

I am using the latest version

I got my problem solved
i changed my project file location and it worked
i have no clue how

I understand from all of this that you need to download a new version of the engine or to download Microsoft Visual Studio 2015. But downloading a new version of the engine got this error.
Error starting the application (0xc0000007b). To exit the application, click “OK”.

Installed Unreal Engine version 4.12.5. The previous error disappeared, but appeared new problem.

----------------------------------------------------------------------------------------------------Log----------------------------------------------------------------------------------------------------

The project could not be compiled. Would you like to open it in Visual Studio?

Running F:/4.12/Engine/Binaries/DotNET/UnrealBuildTool.exe MyProject2 Development Win64 -project=“D:/Documents/Unreal Projects/MyProject2/MyProject2.uproject” -editorrecompile -progress -noubtmakefiles -NoHotReloadFromIDE @progress push 5%
Parsing headers for MyProject2Editor
Running UnrealHeaderTool “D:\Documents\Unreal Projects\MyProject2\MyProject2.uproject” “D:\Documents\Unreal Projects\MyProject2\Intermediate\Build\Win64\MyProject2Editor\Development\MyProject2Editor.uhtmanifest” -LogCmds=“loginit warning, logexit warning, logdatabase error” -Unattended -WarningsAsErrors -installed
Reflection code generated for MyProject2Editor in 7,380223 seconds @progress pop
Performing 10 actions (1 in parallel)
PCH.MyProject2.h.cpp
MyProject2HUD.cpp
MyProject2Character.cpp
MyProject2.generated.cpp
MyProject2GameMode.cpp
MyProject2Projectile.cpp
MyProject2.cpp
[8/10] Resource PCLaunch.rc
[9/10] Resource ModuleVersionResource.rc.inl
[10/10] Link UE4Editor-MyProject2.dll
Creating library D:\Documents\Unreal Projects\MyProject2\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-MyProject2.lib and object D:\Documents\Unreal Projects\MyProject2\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-MyProject2.exp
MyProject2.cpp.obj : error LNK2019: unresolved external symbol “__declspec(dllimport) public: static class TBaseDelegate<class FFixedUObjectArray *> & __cdecl FCoreDelegates::GetObjectArrayForDebugVisualizersDelegate(void)” (_imp?GetObjectArrayForDebugVisualizersDelegate@FCoreDelegates@@SAAEAV?$TBaseDelegate@PEAVFFixedUObjectArray@*****$V@@XZ) referenced in function “void __cdecl `dynamic initializer for ‘GObjectArrayForDebugVisualizers’’(void)” (??__EGObjectArrayForDebugVisualizers@@YAXXZ)
MyProject2GameMode.cpp.obj : error LNK2001: unresolved external symbol “public: virtual bool __cdecl AGameMode::SetPause(class APlayerController *,class TBaseDelegate<bool>)” (?SetPause@AGameMode@@UEAA_NPEAVAPlayerController@@V?$TBaseDelegate@_N$$$V@@@Z)
MyProject2.generated.cpp.obj : error LNK2001: unresolved external symbol “public: virtual bool __cdecl AGameMode::SetPause(class APlayerController *,class TBaseDelegate<bool>)” (?SetPause@AGameMode@@UEAA_NPEAVAPlayerController@@V?$TBaseDelegate@_N$$$V@@@Z)
D:\Documents\Unreal Projects\MyProject2\Binaries\Win64\UE4Editor-MyProject2.dll : fatal error LNK1120: 2 unresolved externals
ERROR: UBT ERROR: Failed to produce item: D:\Documents\Unreal Projects\MyProject2\Binaries\Win64\UE4Editor-MyProject2.dll
Total build time: 73,68 seconds

----------------------------------------------------------------------------------------------------End----------------------------------------------------------------------------------------------------

First of all make sure you’re using Visual Studio 2015, the 2013 is not supported anymore in the new versions (4.10+ I think).
Second make sure at install it you enable the VC++ and if there are DirectX settings in the installer too.

Edit: If you create a clone of a project make sure you remove the folders Intermediate and Saved from the game project, remove it or move to a subfolder then close the VS and reopen and try to compile anothertime.

*The classes and other properties have changed since the version 4.7 to 4.12 you will have problems, make sure you try to use a new sample created in the 4.12 and no use other project name.