Download

When will the Epic Animations be Fixed Please?

The animations in the third person template have their root bone rotated 90 degrees.

All the animations in the Starter Pack (4.8) have no animation at all on the IK bones, hands or feet.

Would appreciate some feedback on when this will be fixed please.

Thank you!

Hi MajorFailure,

This has already been reported as UE-17137. Having said that the bug has been marked as minor and is backlogged. I don’t have a timeframe of when it will be addressed, however I would not expect it in the near future.

Hello Adam, thanks for the quick reply.

I don’t understand how this can be classed as a minor bug, here are a couple of examples from the forum which it seems are due to this issue:

Plus we have two excellent Twitch streams that show the advantages of using the IK bones, but we can’t use any of Epic’s animations in that way currently. Luckily I have Kubold’s Anim Sets which have their IK bones supported perfectly, but there were a few I needed to use from the starter pack.

The Animation Starter Pack should be rejected from the Marketplace for “Insufficient quality compared with other Marketplace products” :slight_smile:

Seriously though, this needs to be fixed as a matter of priority IMO.

Cheers.

Any news on this? I was writing a custom IK system for a client when I discovered this horrible bug. No animations should be allowed on the marketplace that do not make proper use of the IK bones. IK bones are crucial to video game animation. There is no excuse as the IK bones should be set to match their corresponding bones’ orientation and position automatically in the animation software. I know I could export and fix these, then reimport, but that is a big pain to do compared to simply making the fix from the original animation file.

I just added a forum post on this not knowing it was an issue with the root bone rotation, I figured it was something with the way I setup the IK. Once I figured it out I found quite a few posts with the same issue and really no knowledge of when it will be fixed if ever. I understand that it isn’t high priority but I am working on creating content for the marketplace that works best if the animations I create blend properly into the default movement. I’m sure I’ll find a work around or fix Epic’s animations and ship them with the product if that’s the only way but it just makes things a bit more difficult for me. :\

Really I just wish I had figured out it was a bug earlier!

here mannequin animations.rar - Google Drive

Awesome CriErr! I tried the animations out and they seem to work great! Thank you for the help!

I also got word that they are tracking the bug still and hopefully it’ll be fixed officially at some point!

I’m always happy to have Epic and the community help out so much! Thank you everyone :smiley:

First off…Thank you CriErr for taking the time to fix this!! Second, the walk animation seems like it is missing a few frames at the end, it jumps at the end of the loop…the first and last frames don’t match up it looks like it is missing 1 or 2 frames worth of moment at the end compared to the original walk from the TPS template. I never noticed until I had AI walking around using it that it “glitches” on the loop. It is the same number of frames as the original though just the ends don’t match up like the original. I am not an animator, sadly, and this may be asking too much considering you have already taken the time once to provide the files…but is there anyway that you could help with this? It would not only help me but also countless others who are using the files.

Original:
Original.jpg

Dip Fixed:
9049ef97acb7da44ea9e92e6b1982f104e51c4e5.jpeg