When Using 3D Widget on Dedicated Server, "On Clicked" Does NOT Function for Clients ("On Pressed" / "On Hovered" etc Still Function Properly)

Steps To Reproduce:

  1. Create 3rd Person C++ w/ Starter Content (4.15.0)

  2. Follow “How To” Steps in UE4’s Documentation for “Interactive 3D Widgets”

  3. Set “Use Dedicated Server” in Play Settings.

I tested this with a 3D Widget Actor that I spawned in the level through the default 3rd Person Character (instead of using the 1st Person gun, I attached the Widget Interface to the camera and raised it above the character’s head). I made sure to click “Replicate” on everything and even tried manually setting “Replicate” via BP node after nothing else worked. Whatever I tried, I kept getting the same results:

  1. Dedicated Server = ON:
    -A) “On Press” / “On Hover” etc work as expected.
    -B) “On Clicked” does NOT work at all.

  2. Dedicated Server = OFF:
    -A) “On Press” / “On Hover” etc work as expected.
    -B) “On Clicked” works properly.

I haven’t had a chance to test on previous versions of UE4. This is a big problem for me, since my entire menu relies on the 3D Interactive Widget and nearly every button is set to “On Clicked.” I could change them all to “On Press,” but, first of all, that feels weird and it would also take a tremendous amount of time! It could also lead to my own bugs if I miss one or make some other error in the process.

Hey Killmaster-

Thank you for your report. This is a known issue that has been reported here: Unreal Engine Issues and Bug Tracker (UE-6411) . This bug report is currently backlogged, however I have added a note that it is still affecting the community.


yes please my game needs this fixed to continue and im in 4.18