When tabbing in PIE or packaged game, Vive is "stereo off" and in dashboard


I’m having some trouble with tabbing while playing my game. It doesn’t matter if it is Play In Editor or in a packaged game. When I alt-tab the HMD flickers the “SteamVR dashboard” and I can also see my game but the stereo mode is off. This seems to only happen on Windows 10. I have Win7 at home and I don’t have this problem in PIE. I haven’t tested a packaged game at home yet.

A workaround is to enable borderless window. That makes the problem go away.

I tried a basic blueprint project and I get the same problem in PIE but the packaged game crashes on startup for some reason.

2 screens + Vive
Nvidia 1080

Hello engywook,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?
  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?
  3. Could you provide screen shots of any settings/blueprints that may be involved?

Hi Rudy,

  1. Partly, it crashes if i start a packaged game(basic blueprint) for some reason. Play In Editor has this issue though.
  2. Have a Win10 box. Then create a blank blueprint project. Play in VR. Alt-tab to something not unreal, like “File Explorer”.
  3. Nothing needed

Seems I was wrong. I have the same problem, tabbing PIE, at home with win7, both UE 4.14 & 4.15.

Could you elaborate on what you mean when you say that the stereo is off but that you can still see your game? Do you mean that you can still see the game in the headset or something else?

Yeah, sorry. I misunderstood what stereo off would do. When I alt tab there is flashing between three cases.

  1. “Stereo off”, or rather when the vive/hmd is set to “off” and I can see the lighthouses and a 2d screen saying Waiting … or similar.
  2. Normal game
  3. The one I called “stereo off” earlier but it may just be the resolution being wrong I think. This case is similar to if I were to set screenpercentage > 100 in a postprocessvolume, instead of r.screenpercentage in a console command. It’s a little hard to explain but I can see both “screens” in each eye I think.

Hello engywook

After doing a bit of digging I was able to find that this is a known issue. I have provided a link to the public tracker. Please feel free to use the link provided for future updates.

Link: Unreal Engine Issues and Bug Tracker (UE-34309)

Make it a great day


That’s a similar issue but not the one I’m having. When I “Alt-Tab” my game(PIE), the game is not playable. My issue is not the editor itself. I am not exiting SteamVR. The issue is just from “tabbing”/unfocusing the game.

Think of some training session where an instructor wants to do something else on the same computer the student/instructee is using the Vive on. Then the students game is interrupted/“not working” while the instructor is doing something else.

On the Win10 box I only have the cases 1 and 3 above. And where case 1 is the major part and 3 is in the background/transparent on the “left eye”. So this could be two different bugs I guess and also why the explanation has been a little ‘straggly’, sorry.

I have provided an example below. Is this what you are seeing when you alt+tab (or something similar)?


Yes, but that is transparent and I can also see parts of my game in the “background”.

How did you record from the HMD? If I could record my issue it would be more clear.

The picture above was one that I found on google. Also, one of your other answers in a bit unclear. Where you able to reproduce this issue in a clean project? If not, could you provide a project that reproduces this issue so that I could take a closer look?

I used to have this issue both in a packaged project and when playing from the editor. Now I only have it when playing in the editor. Maybe 15.1 fixed it?

Yes, I have this issue if I just make a blank blueprint project.

  • Create project
  • Play VR
  • Tab to file explorer
  • The hmd should now be in “vivewaitingroom” with some distorted version of the game being added/rendered in the background

The SteamVR application is also flashing between the attached image and the normal “UE4Editor.exe” in white.


If you are getting kicked back out into the Vives waiting room, this is working as intended. The vive defaults to this room anytime it goes a certain number of frames without getting information on what it should be displaying.

Well, I still think this is a bug but since it doesn’t happen in a packaged build any more it doesn’t matter to me.