When packaging in UE5 there's no sound in the packaged project even though there is sound in the editor

Further details:

  • I’m using the latest (currently) version of UE5 (5.0.2)
  • There’s no sound when playing the packaged project on other computers too and OBS doesn’t notice any sound when the game is playing.
  • This is a new thing for this project even though I didn’t mess with the project settings since last time I packaged and it worked fine.
  • Packaging a blank project doesn’t have this problem.
  • When trying to open previous packaged projects (of this same project) an error message pops up with the message “XAudio2.7 is not installed”, when it is, in fact, installed.
  • I added an SFX without any values editing it’s volume like everything else in the game and it
    also doesn’t show up in the packaged project.

Hello HeyoLetsgo9, and welcome to the community.

You audio concerns are a bit alarming.

There are a few things I would check for:
VR: I would check if my VR headset is plugged in.
Check if DirectX 9 is installed.

Here is more information on DirectX 9
WARNING: This is an external link and as the end user, you are responsible should something happen to your device when you choose to click a link or follow steps that are not endorsed by Epic.
Answers Microsoft

I hope this information assists you.

1 Like

Hello and thank you.

VR: I would check if my VR headset is plugged in.

Well this one’s easy. I don’t have one. I’ve checked for output options on my pc but everything is just as it was (connected to headphones) and all other media sources (e.g random youtube video/other games) do work as intended and have sound.

Check if DirectX 9 is installed.

I have checked, and for good measures I have downloaded it again but it didn’t work.
I have also tried removing XAudio 2.7 from win32 and pasting it back as some tutorials suggest but it didn’t work either.

Fun fact:
On the third time you try to install DirectX 9, the install will tell you that you already have it installed and there’s no need to install it again (afterwards it closes down and will not install it again).

Although, I did find a solution/workaround.
Migrating all the files to a blank project (well, First Person Shooter Template) and packaging seemed to work. I tried solving both the audio bug and the new bugs that arose from migrating at the same time, but since I made progress much faster at the newly migrated project I focused on it, and it’s now the same as the previous project but without the audio glitch.

My theory is that somewhere in the packaging settings something got messed up. It didn’t give any errors I could find the log so I’m guessing it’s something beyond just my code.

Thank you Polite_Muon and goodluck to all of the internet strangers that came to this post due to a similar problem.

Thank you for replying with not only a feasible workaround but with some great nuggets of knowledge!

Since you have resolved this, I will mark your in-depth, insightful reply as resolved.

1 Like

Just wanted to come here and pass the torch to the next guy! More than likely it’s a directory issue. Try repackaging see if your exe changes. Audio files worked in editor and in package but not in steam files then that’s the issue