When Importing skeleton mesh to Unreal 4.9.1 Rig Breaks

I’m running into an isssue with my skeleton mesh and can’t seem to get it working right. When I import the skeleton mesh into unreal 4.9.1 My rig Breaks. The eyes from My charatcer pops out of its sockets.

I have tried various Way of fixing the issuse but no luck. I looked back at the rig in maya to see if I missed anything and there seem to be nothing wrong with my rig in maya. I leave the import settings the same also I updated from 4.8.3 to 4.9.1 thats when the isssue started. I dont know if converting back might help or would it make more problems.


FBX and UE4 not support custom rig, which was created in 3d program. Before export, you need bake animation into skeleton and delete rig and other helpers. Because exporter do this self and usually with errors. And check FBX version in export parameters. Default - FBX2016, and you need switch to FBX2015/2014.

This is video tutorial about how to prepare character for export to UDK. This work for UE4 too.


And this is official docs for FBX pipeline:

I’ve tried the method that you provided by switching the FBX format from 2016 to 2014 in Maya. Im still running into issues with the rig when importing it into UE4. I decided to try to put my character’s rig in a different engine like Unity and it works fine. There seems to no problem with the rig and the FXB format (when in Unity). I dont know if its the recent updated that Unreal 4 had made which is causing the rig to break, but charging the FBX format doesn’t seem to work.