When i open epic games launcher it starts to rapidly open and close

Hello,
I have just downloaded epic games launcher, so I can use UE4. But I have a problem. When I try to open epic games launcher, it starts to open and close so quickly, that I can’t even click on it. Same problem after restarting PC and after redownloading installer. Do somebody have experience with solving this problem?

Specifications:
windows 10
Nvidia gtx 1050
i5 7300HQ
8GB ram
64 bit

What OS are you on?

Here are a couple of things that you can try:

  • Check if it is running in the background
  • Run the launcher as admin
  • Turn off your antivirus software
  • Make sure that your OS and drivers are all up to date

Try to find an error log or something like that to give more detail as well!

I have windows 10. I tried everything you writed, but nothing helped. I can not find any error log, even in windows safety settings. While glitching, it do not tell me something too. And it is not running on background.

Ok thank you for help, I finally solved it. I changed graphic settings and now it is working.

I have the same problem and can’t figure It out, what did you change?

Luc

Im in the same boat, please post the fix @TenGraphex

Anyone get the fix yet ??? Unable to use Epic Games Launcher still …

hey guys after 2 months struggle of reinstalling epic, graph drivers even win…I solved problem by changing display resolution to 1280 720
update not long term solution…

Found here on Youtube, it worked for me !


From ali onagh

guys i finally solved this forever on my laptops, i was struggling with this issue for a long time and on many games and launchers, i knew it was intel (integrated GPU) and nvidia switch failure, but i didnt know how to solve it, so listen:

  1. go to intel download center and find your latest intel GPU driver for your laptop here:
    Support for Intel® Graphics
    but don’t download the “exe” one, download the “zip” one (because the exe driver file never installs for laptops with two GPUs).
  2. extract the zip file in a folder on desktop.
  3. Right click My Computer => properties => Device manager => display adapters => intel HD graphics => right click => Update driver => Browse my computer for driver software.
  4. address the unzipped folder that contains the Downloaded driver.
  5. after finishing update restart the laptop.
  6. enjoy

hi. What eventually worked for me was turning off my onboard intel video card, so only my Nvidia card was active. Not Perfect but it works for me.

worked for me(acer vx15)
thanks a lot :smiley:

Hello!
I encountered the same problem. To fix this I went to my settings, in there search for graphic settings, then turn of Hardware-accelerated GPU scheduling.
This worked for me and I hope it works for you…

This fixed it for me but for some people it isnt working

I added in Settings (Win 10) → (type in search bar) Graphic settings → (choose version of .exe that shortcut is working on - mine was Win64) and Power saving - Inter processor integrated card (Wasn’t working on Nvidia card - was still restarting like crazy )
Cheers