When I launch my Variables are set to 0 and I can't Jump, what shall I do?

I’m currently working on a 2D Game based on the Kenney Sprite Pack, and it’s perfectly working in the editor Preview, but as soon as I launch or package the Project, the money and Healpott Variables (probably some others too, I didn’t check it) are set to 0 and I’m unable to jump!!! I tried to launch it in 4.6 and 4.8, but it still didn’t work… After that I couldnt even enter the Project!!! Can anyone help???

Hi crafter111211,

We’re going to need a lot of information from you in order to investigate this issue. Please have a look at this thread for a template of how to begin. Further, if you can add to what device you are deploying your project, along with its OS.


I am using and deploying it for windows and if you want i can post screenshots of the neccesary BPs

Yes, and if you can answer the questions in the thread I linked above and add that info, we’ll need it to begin assisting you. Thanks!

SRY, for taking your Time, i have solved the Problem on my own