When I enter the default value of a Float variable it changes when I hit enter?

Hi, I’m new to this so I may be missing something simple but, as the question says,

When I create a Float variable in a blueprint and try to enter the default value for it, the value changes after I hit enter?

Am I missing something simple or misunderstanding how these work or something? Could somebody please explain?


Hey DanielFawcett-

There does appear to be a bug with the value changing if the number of digits is greater than 8. This has been reported and can be viewed here: Unreal Engine Issues and Bug Tracker (UE-35802)

As A workaround, I would try creating another two float variables. You can then use two of the 3 to store numbers that add up to the desired number, and store that in the third without directly setting it.


Thanks for the reply , much appreciated

I don’t have unreal handy on this computer so I can’t test it, but do you get the same result when you tab out instead of using enter?

Yeah, whatever I do it just shuffles the last few digits.

I have tried what suggested below and used additional variables and combining them together with no luck. Any value with more than 8 digits is just shuffling the end of the number (displayed when I print it to the screen)

I am getting this error with 5 digits… I try to enter 273.15 and it changes it to 273.14449…
Using 4.23. Seems like a pretty serious issue not to be able to enter a number into a box…