Download

Wheeled Vehicle Collision Problem (Exporting from blender 2.78)

I’ve tried everything and still can’t make the Wheeled vehicle BP to work. I am using blender and creating a vehicle from scratch. The wheeled vehicle collisions don’t seem to work right. They don’t snap to the wheel bones.

The rotation of the wheel collision looks good, but the position is not. Also the position of the wheel collision changes when I remove/don’t add primitive box to the root bone. I have 6 wheels, but I am trying out 4 wheels for now.

I get this all the time:

Blender:

Tried so far:

  • Followed exactly everything like in Vehicle template.
  • PhysWheel (Not weighted bones for the wheels. Like in vehicle template)
  • Rotated all bones to the left (y+) / Reseted the bone roll
  • Different names (don’t think it does anything, but gave it a try anyways also tried “.” or “_” in names)
  • Moved the pivot down to 0,0,0 and the vehicle up (I think this fixes the jiggering/flying vehicle)
  • All the bones are Vertex Grouped
  • Joined everything into 1 mesh
  • The Vehicle is pointing towards X forward and Z up
  • Applied rot/scale/loc before exporting.
  • Without bones (With empty axes plains, still get the problem with the collision)
  • Tried Exporting with “!EXPERIMENTAL! Apply Transform” turned on in blender. (Worked for mesh bones with experimental option on, they snapped to the wheel location but wrong rot.)
  • Tried importing and setting in new Unreal project.

Offsetting the wheels would fix it temporary, but thats not helping much.

Could someone try and create a working vehicle with the rig or point out what I have wrong in the blender rig or if its a bug or its blender/fbx related or if you have a similar problem. Here is the rigged FBX

I would really appreciate if anyone could explain what exactly is wrong.

make sure your wheels are skined to the correct bones

on import tick the box ref pose

btw you’ll find various blender vehicle tutorials in my youtube channel

Hello thx for replying. By skinned you mean weighted bones and I had “Use T0As Ref Pose” ticked already?
Nice I will check out your Youtube tutorials. George Davidson right?

I’ve literally tried most of the options I know of or seen of. For a few days now. Followed examples on you-tube and I still can’t get the collision to work right.
I’ve tried already rigging 3 different meshes from scratch.

Already rigged meshes work fine (exporting from unreal engine, tweaking the bones and then importing back)

It’s skinned, x forward, z up, bones x and z same and vertex grouped.

Here are the rigged test projects. (Simplified it to 4 bone wheels and 1 bone body) The FBX, Blender project and Unreal Engine project:
FBX 7.4 binary
Blender 2.78
UE4 4.14

You are using the wrong scene scale in Blender, you should set it to 0.01, scale the armature up 100 times and apply transforms for the rig and mesh and try exporting again. You also need to set up your physics asset right, you shouldn’t use the armature bone as a body. Actually you shouldn’t even have an armature bone if you “fix” the Blender FBX exporter. (google blender extra root)

Yes this fixed it thank you so much cyaoeu.

For anyone with similar issue. Just Change Scene scale to Metric, Degrees, Unite Scale 0.01 and then scaling the whole mesh and armature up 100 times and then apply transform.

About the root bone. Blender Extra Root assuming its this one? From what I understood I make my own root bone and weight/skin the whole mesh to the root bone. Instead of making 2 bones (extra root and body bone)?

By default Blender makes the armature modifier the root bone which isn’t great. If you want to animate root motion for example you need to do that in object mode which is a bit strange. Maybe for a vehicle that doesn’t matter but having a normal root bone in your rig makes a lot more sense. It’s also better that way since you can share skeletons between similar meshes if the top bone is called “root”.

In your example you could have a body bone parented to the root bone and the wheels parented to the body bone. Then in the physics asset I guess you would only have bodies for the body and the wheels.

Alright thanks for clarifying and again thx for all the help.

Can you please explain a little better, I tried to apply scale to 100, 0.01… several combinations but still not working… I mean, if I apply scale I get a giant mesh on UE4 (that is working) but if on reimport settings I set scale to 0.01 I get back to the same problem as before

^^^ buuuuuump!

It’s not 0.01 on reimport settings, it’s the units scale in Blender. UE4 uses centimeters as its base unit, So to set that in Blender, you first change units to Metric then set scene scale to 0.01 (the number just below the units). Which, in Blender’s case, will divide Metric 1, as in 1 meter, into a onehundredth, as in 1 centimeter.