What's rendering / displaying the UMG

So I made a brand new empty C++ project, created a umg userwidget blueprint, and hit play. I’m assuming the GameMode createsobjects when play begins if these objects do not already exist. (CameraActor, DefaultPawn, GameNetworkManager, GameSession, GameState, ParticleEventManager, PlayerController, PlayerStartPIE, and PlayerState)

So… when I went into playmode, I went through and deleted every object in there (0 actors is what it said afterwords), but my UMG widget that I created on Event Being Play in my Level Blueprint was still being rendered… by what?

Another question: From a mobile standpoint, how do I change the aspect ratio of a camera I can’t find so that it displays in portrait mode? Is that even the correct way to set the game to portrait mode? (versus landscape of course, which is default in UE4 and so far seems forced upon the developer).

I’m somewhat new to Unreal, coming from Unity3D. In that engine there was a property in the project settings where you could set all the orientation settings (portrait & landscape, portrait only, landscape only, etc.)

Thanks a bunch for everyones time! Hopefully someone can educate me :slight_smile:

  • Austin

Hello AustinK,

Ratio issue:

If you would like to change the aspect ratio for your UMG to portrait you could open up your widget blueprint and click the “Resolution” button in the upper right corner of the designer tab. From there you can choose what your looking for. There is also a custom select where you can manually put in what you would like. I hope this helps.

Setting up UMG:

Setting up Editor:

Display question:

Could you still interact with the widget (click buttons and that sort of thing)?

From what I understand, those ratios for the UMG designer are only for setting that specific widgets target resolution. For instance if I set everything to anchor the center, just offeset everything for positioning, and played the game on a rosolution wider than my target, I would just have empty space on the left and right side of my UI.

And yes, when I delete all actors from the scene my buttons are still receiving a hover and pressed event from whatever is managing that.

Hello AustinK,

I misunderstood your question originally.

Here is how you set Android and/or iOS devices to portrait:

These can be found in project settings under Android and iOS respectively.

As for your display question:

No actors are created in the scene for represent a Widget. Create widget does not create an actor. If you would like to remove it you can use the “Remove from Parent” node.

Thanks! That’s what I wanted. I appreciate your time and help. It still amazed me how helpful this answer hub is.

Can you move this to an answer section so i can mark it as answered?