Download

what's going on with my assets/materials?

so i recently changed my rig to something much powerful, i reinstalled windows 10, all my softwares and games, and of course ue4, i only exported one of the projects i’ve been working from the previous year, so i started a new firstperson example project to see how the things are working now, and i got this 4a0ad9a680431e548783af27d856deab52e71e79.jpeg and things are stranger, since i created a few of the examples from community, learn, marketplace, etc. and most of these had the same issue, pretty weird cause this never happened to me with my lower rig

That weapon looks like it has all the triangles winding in the wrong direction and/or backface culling is backwards.

Hmm, could be problems with current drivers I guess?
Are you getting this on skeletal meshes or just on everything that is close to camera?

well i found out this is related to the mesh, when i select the wireframe, you only see what’s shown in there, a bunch of weird assets cut in pieces, i thought it was the material, but when i select the asset, the outline appears on the entire mesh, for example, if this is a rock, you select the rocket and the outline shows the entire rocket, but when i put the wireframe mode, it only shows the pieces, ps: i’m unable to post images right now, i’m getting a database error

Yes; my guess is that, when you exported the mesh, you exported it with triangles winding the wrong way (or in a left-handed instead of right-handed coordinate system setup.)

i didn’t export anything, my personal projects works right, anyways, i got 2 images to see that this isn’t a minor issue/bug, might be something related to a bad installation? or drivers? i really don’t know http://imgur.com/a/rnr33

i really need help, i don’t want to reinstall unreal engine 4, which will take me around 3 hours, i need to check if there is something that i might to do to fix this quickly, after taking the risk of reinstallation

Did you not import that model from .fbx files?
If so, where did the model come from?
This is either a bug in the model, OR it’s a bug in your graphics drivers (but that seems highly unlikely.)
You do not need to reinstall the Unreal Engine.

One thing you can try is to check the “two sided” property in all of the materials that render the mesh:

5dd824a7d1de534f26728dc49de0308ed3d3812a.png

i changed the blend mode to opaque since it was in masked, but it didn’t worked either, i guess i’ll have to reinstall

i ended up reinstalling unreal engine, launcher and engine, obviously doing a clean up on registry and everything that was causing any troubles, everything looks the same :frowning: as you can see here, the meshes are weird, it was not related with the materials but the mesh 3dcf5d5d35326ec976b78e1c59fa9525ee353ea7.png

Yes, as I said, the problem is that the triangles wind the wrong way in your meshes.
The question is how they came to be that way.

Separately: Did you actually turn on two-sided in the material and see if that worked around this problem?