What to do about pesky string asset reference warning

Ever since updating to 4.17 I get warnings like the ones below:

LogPackageName: Warning: String asset reference "JW_FlameDungeon.FX.SM_FX_Embers" is in short form, which is unsupported and -- even if valid -- resolving it will be really slow.

At some point I resolved them by painstakingly finding out which asset and where and then either deleting it or fiddling with it until the warnign disappeared, but they keep popping up like mushrooms.

I mean if “resaving” solves it (which it often doesn’t) why isn’t there an automated way to upgrade all packages automatically or handle this in a better way?

Do I really have to dig through each and every warning and fiddle with it manually? many of these are in the free Epic packages like Iceland etc. So if these packs are from Epic itself and buggy, that’s pretty bad looking in my eyes.

Does anybody have a tip how to handle this efficiently?

Have the same bloody issue, what do you mean by fiddling ? What to so to fix them ?

Basically guessing where you use that asset, like a level or a BP, then opening that and compiling/resaving it. If you have no idea where you use it then you could simply delete it (rather remove it from your project with Windows explorer so you can copy it back) and then restart your project which might give you better error messages where the asset is now missing.
You can try the “find in blueprint” feature or the reference viewer, it’s basically just pocking in the dark.
It’s a lengthy task sometimes you have to just try and save and hope the best, it sucks that there is no better way to finding thiose references.

Thank you for your answer, however for me it was kind of strange - I tried to rename maps resave them whatever nothing worked I tried to export and reimport the assets - nada…
then I just change the name if the directory in the ContentBrowser and magically it started to work…
Needless to say it happened with Epics free assets… and also happened for the new clean project.

Yep I have a few assets that UE whines about every time I start my project. I tried to create them in the desired location per hand but UE still complains it can’t find them. I don’t know where they are referenced and havent found a way to get rid of the reference. Some things are just bugged and they don’t fix it because it happens rarely I suppose or is not high on their list