Download

What the *#%!@ is going on w/ editor in Mac - stays in foreground?

I’m trying to use the Unreal editor on a Mac, and it won’t let me use any other program, like Safari for instance. Unreal keeps bringing itself to the foreground, so that every time you select another window, like a browser window, it immediately becomes deselected. This makes it impossible to use any other programs while using Unreal. So I can’t switch to XCode, I can’t look anything up online. Is this a known problem? I don’t see any other topics here about it. If it is just something I have done, can anyone tell me how to fix it? It is crazy annoying!

I am not having that issue here, MBP, macOS 10.14.4. I am actually typing this in Safari with UE open but in the background. I haven’t had to do this, but can you not cmd+H to hide UE when you need to switch apps?

Did you figure out a fix? This keeps happening to me as I am trying to learn UE4… I don’t know what the f is going on but it is quite the bug.

I’m having the same issue on a Mac running Catalina 10.15.7 and UE4 version 4.25.4. It seems that when I open any type of new window this foreground issue occurs and I have to totally exit UE4 and reopen it again. A mate suggested having new windows open as tabs (preferences) but this doesn’t solve the bug issue.

Currently happening to me on Big Sur 11.1

Spent days reading and watching about unreal only to have this happen on first opening, completely stopping me from doing literally anything else at the same time, like tutorials or Blender.