What is wrong with the "Epic Games Launcher" download?

I just got into the Paragon early alpha, and was super excited to play. To do this, the Epic Games Launcher needs to be downloaded from the Epic online site first. No biggie, I boot it up and download the app like anything you would off the internet. However upon trying to open the app, I get this error message. “Windows cannot access the specified device, path, or file. You may not have the appropriate permissions to access the item.” I ran through all the different forums and couldn’t find a solution. As I’m the only user on my PC, with all Admin access, I don’t understand this problem. I tried repairing the App through the website, to no avail. I was hoping you’d have some advice for me to fix this issue? I’d love to hop into game.
P.S. Yes, I have tried turning it off and back on again.


I’m sorry that you are having an issue with the Epic Games Launcher. In order for us to offer the best support, we have recently modified the process for how Epic Games can help troubleshoot your Launcher issue. Please visit http://help.epicgames.com/ for technical support, here you can find information and solutions for common issues, as well as a contact form if you still need additional assistance. Thanks!

If you need further assistance with Paragon, please check the Paragon help site at Paragonhelp.epicgames.com.