What is wrong with my Gate?

Hey, new here. Pretty new to blueprints too so bare with me.

I have this Gate in my Widget blueprint. The Custom Event there hits the Print node, printing “Open”, but I never see the other Print node print “Flow”. Please help me understand why.

I thought if the Gate is open (which it should be because I see the engine print “Open” and nothing is closing it), the Tick would print “Flow” forever. But all I see is “Open”.

idk try plugin something into close…

I originally had another event there, but it never got called because the Gate doesn’t work, so I removed it. Tried a few things there. Doesn’t seem to matter what I plug into that or the Toggle input.

If I untick “Start Closed” I get to the exit no problem and see “Flow”, so there should be nothing wrong with the tick etc… I tried the breakpoint on the Gate, and it does get there, and that’s it. I’ve never used a breakpoint before, does it provide any other information? I’ve used Gates before though, but never in a Widget as far as I remember. Is there something special about Widgets that can kill the Gate?

Well hey I tried it… Log is outputting fun stuff:

LogSlate: Warning: Slate: Had to block on waiting for a draw buffer
LogSlate: Error: Attempting to pop clipping state below 0.

No clue what any of that means, but probably that I shouldn’t Breakpoint Ticks. But really, what can even theoretically be affecting this thing? I’m missing something very obvious here for sure. I used to have a loop there instead of a tick, too, which also didn’t work. Just kind of using Tick to test it at this point.

I’m sure that’s what’s wrong with it. Something in the logic, it’s a big mess out there :wink: I create the widget only once… Unless it’s some other random blueprint somewhere creating it, ughh… But good to know that’s what COULD at least cause it and the problem doesn’t HAVE TO be in the Widget itself.

It’s not visible because the Widget itself is controlling what is visible inside it, and it never gets to that logic because of the gate. It’s a fairly complicated Widget, not just a little HUD. I used to have it without a gate and it worked - kind of - just used a lot of resources because it wasn’t being called properly and was always on. That’s why I’m trying the Gate.

UhhKay, pretty much SOLVED now. I had another blueprint conflicting with the one calling the Open Event. It created the widget on game start. So this is something I didn’t know: If you create a widget, and then create it again, It stops the Tick. Or any other Event except the one you initiate?? Can someone explain to me what happened here? But thanks, Clavos, for your insight.

To clarify this is a Widget for dialogue options, so they’re constantly being refreshed while normal gameplay is all but stopped. And yeah I’m not going to use Tick, just looping some stuff.

And that makes so much sense now that you say it, that it has its own tick… It’s an old widget, that’s the problem. Didn’t realize it was initiated elsewhere.

I don’t really want to move the logic outside of the Widget though, because it’s receiving inputs from a bunch of pawns running different dialogues. They already control the stuff they’re saying, this Widget just kind of reorders that stuff and pushes it on screen. But thanks again, I learned something :slight_smile:

My pawns invoke those custom events that enable/disable a loop for the dialogue options with the Gate, not using Tick, just a loop. I was trying to keep it simple with the Gate. Funny how that worked out!