Download

What is up with the ragdoll on clients in multiplayer game ?

Check these links :
https://answers.unrealengine.com/questions/118390/ragdolling-replication-broke-for-me-in-45.html
https://answers.unrealengine.com/questions/117608/45-client-side-physics.html

I have the same issue and it doesn’t seem like there is someone who knows how to solve it.
Will it be fixed in 4.6?

I really need this one solved! I don’t want to release a version with this kind of behavior.

I belive this may be related to the problem you are having.
https://answers.unrealengine.com/questions/128514/451-i-had-to-revert-to-43-again-set-simulate-skel.html

Epic have a tech on this so am hoping its resolved in 4.6 its realy a development halting issue.

Thanks. I don’t get why epic didn’t respond on any of those threads…

What WCode said!

And the reason for my rather emphatic title to my answerhub post:
https://answers.unrealengine.com/questions/128514/451-i-had-to-revert-to-43-again-set-simulate-skel.html

Rama

I just want to update, As i said in the answer hub :

If i wait about 1 minute, the ragdoll stoped being glichy and start functioning like it should with no bugs at all, like it takes about 1 minute to “Relax” or something…

Edit : I’v added a video of the problem with explanation in details ( Watch in 1080p to understand better what is going on ) :

Hey guys, we have a few people looking into this and we’ll keep everyone updated as we get to the answer. It may be a limitation and not a bug exactly, but it is definitely something we will address soon. Thanks for being patient with us while we investigate.

Thanks Alexander!

Please remember that everything worked great in 4.3 in regards to skeletal meshes simulating physics on client machines.

My game still runs perfectly in 4.3, and that is where I have to stay until this issue is resolved.

I’ve tested multiple times, just upgrading to 4.5 causes the issue.

I have a video of this at my answerhub post:
https://answers.unrealengine.com/questions/128514/451-i-had-to-revert-to-43-again-set-simulate-skel.html

Please dont tell me this is a “limitation”, this is a game-breaking engine-reverting issue that must be solved!

Everything works great in 4.3!

It must be a solve-able issue!

It used to work!

(not directed at you Alexander, but do recall that I am stuck on 4.3 because of this issue)

My physics-based multiplayer game simply cannot work in 4.5 because the server proxy disappears on the client constantly, as shown in video at link below.

https://answers.unrealengine.com/questions/128514/451-i-had-to-revert-to-43-again-set-simulate-skel.html

Rama

PS: I am also working on two FPS multiplayer games that simply do not look good for the client because when the proxies of other characters ragdoll, they go completely bonkers and then disappear, or simply disappear instantly (they go to the origin as others have mentioned)

There are at least 3 answerhub posts about this issue and I am working on approximately 4 multiplayer games that are directly affected by this issue. It is not isolated to one project!

Also I’ve counted at least 8 distinct people who use the engine routinely as speaking up about this issue, and that’s just the people I know of who are also vocal :slight_smile:

Please understand that whatever the reason that this issue cropped up in 4.5 alone,** this issue simply has to be resolved for anyone doing a multiplayer game involving ragdoll physics.**

I’v solved it !!! All you need to do is to destroy the movement component and disable replication before starting the physics simulation. all the clients will see the ragdoll and you too and it will works great !
I’m so proud of myself :")
Capture.JPG

@Sahkan: Glad you found a way, but this also includes Static Meshes and Skeletal with no movement component
(also something going on with the Destructible Collision on chunks yet to be determend).
Physic Replication is also stile broken in 4.6 stile disapers but Epic been very good at telling us whats going on with this issue.
They have devs working on it now, so am prety sure we will get a hotfix as soon as they come up with a solution.
TJ Ballard :diamonds::diamonds:STAFF (2 Days ago)

Link to full AnswerHub Post here.

If you look close you can see he is also approved my solution as good :slight_smile:

Yes i seen it ;), am assuming that the Blueprint image snippet is in your Character/ Player Blueprint?
Am going to test setting the replication to false and activating physics but i cant`t see how i will get the correct behavior then.

For Pawn/ Character this may be a good work around, but for other physic simulated objects?

There is a full solution for this issue now, from Epic Zak Middleton.

Many special thanks to Sahkan for finding a working solution that informed the final C++ solution

:slight_smile:

https://answers.unrealengine.com/questions/128514/451-i-had-to-revert-to-43-again-set-simulate-skel.html

Rama

Sahkan, thanks for finding the solution! However, it doesn’t seem to work for me, can you please post a screen of the whole ragdoll part in BP? Thanks in advance.