What is causing the fps drop in projects between 4.14-4.15?

I was profiling a project of mine, and trimmed everything down as much as possible, yet was stuck at 150 FPS (which I’ve seen 300 FPS before, so it struck me as odd.) Then I tested the SAME projects in 4.14 and got 400FPS. Then I tried in 4.13 and got 600-800 FPS. (On a GTX 1070, I7 3930K, 16GB RAM)

Step to reproduce:

  1. Start unreal engine 4.15, create a default third person template
  2. Run the game in standalone mode, enter commands: t.maxfps 1000 and
    stat fps
  3. Note the FPS in the top right.
  4. Repeat this in 4.14 and there is a noticeable difference in FPS.

Any help is appreciated, I was driving myself up the wall thinking it was something I did wrong, just to realize I changed engine versions. @_@

i would imagine it running slower due to it having more content than the previous engine. also check if forward rendering is on.

Whilst I appreciate you trying to help me, I would like to believe that it’s not “500fps to 300fps loss” amount of content. Also, testing your suggestion, forward rendering did increase my FPS in the above test to 250 in 4.15.

Hello IcemanX,

I tried reproducing what you’re seeing but I’m not seeing any changes. I tried both creating a Third Person project directly in 4.14, checking the fps, converting it to 4.15 and checking the fps, as well as creating 2 separate projects in those two versions. In both cases the FPS was hovering between 450-500. Could there be some settings that you’ve changed in one of these versions that could change it? Possibly the scalability settings are different?

You could reset them all to default by going to your installation folder (default is C:\Program Files (x86)\Epic Games\4.15), open the Engine/Config folders and then delete the .ini files listed in this location. Then type %appdata% into your Windows Explorer file path, navigate to


and delete the Intermediate and Saved folders. After doing all this, run the Verify operation on 4.15 from the Epic Games Launcher to restore the lost files.

This should effectively reset all of your settings for that engine version.

I’m willing to believe that my settings for 4.15 are different in some way, but if they were, I would not know why or how. How would I go about resetting my 4.15 install to default? Should I delete it and re install it?

Okay, I’ll update you in about three hours on how that went. Thank you very much for taking time out to help me, since this is not a bug.

Okay, Update. I’ve reset everything and verified as you instructed, and just to be safe, I created two new projects to do the FPS testing in, and no luck, still stuff at 200FPS in 4.15.1. The 4.14 testing is done with version 4.14.3.

I’ve attached two pictures to help show stat unit numbers, maybe that would help narrow down the cause.

I’ve now reformatted my computer, because I was previously on a windows insider build, and I’m still encountering the odd frame lock error. Could it be that my CPU is too old for 4.15 onward? If someone could provide me with the specs of a pc able to get more than 200 frames, I’d be grateful!

I’ll continue looking into this, but in the meantime, if you think it could help you determine the cause, I’ve attached the dxdiag for the machine that I tested this on without any issues.

link text

Okay, an update. I’ve tested various things, and tested my parts in several friends computers. I think it may be related to my motherboard, the original 2011 (v1).

Something between that and my CPU is making unreal engine 4.15 unable to hit the frames I could previously. Either way, I will be building a new AM4 Ryzen development PC this wednesday, and from all my testing, that’ll fix it. I’ll update this one more time once I have the new PC running, but you can close this as solved, I suppose. I cannot figure out what would cause a x99 2011v1 motherboard to have these issues.

I’ve attached a dxdiag to this, in case that would help anyone in the future.
link text

Thank you for that information IcemanX. I have a question, as we’re looking into this issue elsewhere at the moment. Are you using 4.15, 4.15.1, or 4.15.2?

I’m using 4.15.2. If it’s helpful, this issue also persists in unreal engine 4.16 preview 1,so I’m thinking one of the changes applied in unreal engine 4.15.2 tax older chipsets.

We were looking into an issue that is a regression from 4.15.1 to 4.15.2, but since you were experiencing your framerate problems in 4.15.1 previously, it seems to be a separate issue. I’m looking forward to seeing what kind of results you get out of your new PC.

May I ask if there is information about the regression? I don’t remember for sure when I updated from 4.15.1, so they could still be related.

I’ll have the computer built in two hours from this posting, so I’ll update with that information soon. I’m highly certain this will fix the issue, because every computer configuration I tested, including with the same gpu and ram, the only things that changed that still had the issue were the motherboard and cpu. I would like to believe that the cpu is not the issue, so I suspect the motherboard. I could be wrong, however.

The news are not very good for me, is this due to some poor optimizations or due to the fact that the engine really eats up more in 4.15? I’ve noticed the same thing with vegetation, in 4.15 the fps dropped to a quarter for me when using grass. (when it worked very well in 4.13) I was forced to use ‘dithered lod transitions’ something that was not required in the previous version.

Should we wait until 4.16 when it’s optimized better or it will just use 4.13 if we target PS4? Since asking the users to upgrade their motherboards on the PS4 is not really a solution :slight_smile:

By the way, paragon is which engine version is developed? Or is it a custom branch?

Thanks a lot for your time!

Okay, an update. I built the new computer, and the FPS are better (300 area) but still not where they should be. I also notice that on the PC’s that work properly, the profile gpu looks normal, but on my computer, setupmips seems to be taking the entirety of the profileGPU. Perhaps it’s directx related?

Related to the new ‘texture’ streaming feature that streams only visible static mesh textures in and out? There are also some funny vegetation issues.

Maybe 4.15 is not very stable? It is quite important since it makes a huge difference if you build for PS4.

Also try out with some vegetation, it seems to eat the whole GPU/CPU when in 4.13 it was running incredibly smoothly.

(maybe see my comment below too).

That’s the thing though, SOME computers can run it smoothly. The ps4 probably can. Have you tried running your game on the PS4 and checking the FPS there? It changes based on device. I’m just trying to narrow down the cause. It does not seem to be entirely motherboard related.

I don’t have a PS4 devkit but i’ve experienced the same symptoms you have descried with your PC. I presume that one of the new features doesn’t work as expected.

I was thinking that it’s related to something like foliage maybe? Since it doesn’t work well any more.

After that I’ve saw something related to this:

That was not a problem in 4.13. Also grass LOD’s don’t seem to be working.

But now I don’t really think it’s related to the grass, maybe the new GPU texture streaming feature? Is there any way to disable it maybe?

P.S: I’m quite sure it’s not your PC