What happened with textures and rendering in 4.9?


I have some problems with half of my skeletal meshes after migrating to 4.9.

A lot of them now look all shinny and covered with silver (compare the dragon in 4.8 -left- and 4.9-right-, both taken in same conditions in the skeletal mesh preview window):

and one horse even got a large invisible gap in its texture, while the thumbnail is still ok

with a disastrous result (left = 4.8, right = 4.9):

Anything i can do to fix that ?

I have so many serious and improbable problems with 4.9 that i’m starting to wonder if my migration went well. Is there a way to check how things went and whether my 4.9 version is all right ?

It’s currently unusable and i will have to roll back to 4.8, but that can’t be a long term solution.




Quick update, this morning the horse texture is allright. I touched/modified nothing.

It’s kind of frightening, random data corruption ?

Still, the silvering effect is still there. Would normals/tangents corruption be possible during the migration to 4.9 ?


Hello Cedric,

So, from what you described you had a project in 4.8 and then migrated into 4.9. After the migration what you see is a silvering/corruption on your textures.

There is a test I would like for you to do. I would like for you to create a new test project in 4.9 that is completely blank. Then I would like you to import your texture without anything else and see if you get the same result.

There could be some random corruption occurring when you migrated your files. These issues appear to be random and happen when migrating from 4.8 to 4.9.

Please let me know if this fixes the issue or you still see the brightening/silvering effect in the new project.

Thank you,

Hey ,

I did what you asked and think we’ve got 2 separated problems here.

I could not reproduce the horse texture corruption problem, no matter how i tried (fbx, direct texture import), so this is still a mystery.

But the silvering effect is absent in a brand new 4.9 project.

Here is a picture, on the left is a brand new 4.9 project and on the right, my migrated 4.9 project.

Both pictures have been taken using the same freshly imported fbx file.

It seems that the problem is the ambient light being too strong in my project.

I tried to weaken the exposure but even to the minimum everything is dark but the problem is there.

Any idea where that could come from ?



PS: the dragon appears to be ok in game, but i need the skeletal mesh preview window to work, as i am using it to take all the pictures for the game UI.



UE4.9 has broken a lot of materials in my project by changing the “material domain” (for example moving a standard material to “UI” ???).

Check all the material options.

Hello uced,

I have imported a cylinder into a 4.8 project and then added it to the project to see in the viewport. I then saved and closed that project. I then opened 4.9 and copied that project into 4.9 to see if i could recreate the silvering issue you were experiencing.

I was unable to recreate the glowing grey result on my material.

If you are willing I would like to test your model specifically using the same steps to recreate this issue. I would need your .fbx and your materials associated with it.

Let me know what you think,

Thank you,

Hey ,

The problem is not with the mesh, it’s with my project.

In the following image, you can see it happening with the UE4 mannequin.

On the left is a brand new 4.9 project, on the right is my migrated project.

See the silvering effect on the mannequin’s knee and ankle.

But most importantly, compare the ambient lights. In my project, the whole picture is filled with white, this is where the problem is.

So what i need is a way to correct the ambient light (or whatever light problem there is) in the skeletal mesh preview window.

All the best


Hello Cedric,

I apologize for the confusion earlier. I understand that the issue was with the migration of your project from 4.8 to 4.9.

The test that I was going to try was to take a .fbx from your project and add it to a blank 4.8 project. Then I was going to copy that project to 4.9 to see if I could reproduce your issue.

I do see that the picture you have linked, after migration, has an ambient lightening of the whole scene.

I created a test in 4.8 by creating a third person project when launching 4.8. I then opened that project in 4.9 by launching 4.9 and opening a copy of the 4.8 version.

These are the results.

This is the 4.8 result. .

This is the 4.9 Result.

As you can see, there is no lightening of the ambient lights. As you mentioned earlier this could be a project specific issue. If you are willing I would like to test your project on my end to see if I can reproduce the same result. It could be as simple as an option that either needs to be enabled or disabled.

In order to do this I will need your .uproject file, and your content and config files from your projects directory.
Let me know if this is something you would like for me to test.

Thank you,

Hey ,

Unfortunately, the project is more than 10 go heavy, and pretty much all of the content comes from 3rd party sellers and i don’t have the right to distribute it outside a packaged game.

So, being unable to send you the whole project, i suppressed everything i could in it without breaking its opening.

I could downsize it to a manageable size (the archive is about 500 mo), so here it is:


When opening it, you’ll get the following warning but don’t pay attention to it.

Then, go to Content\ThreeDCharacters\UE4Human\UE4Mannequin and open the UE4 mannequin skeletal mesh.

On my computer, with this minimalist skeleton of project, the problem is reproduced. The following picture was made with the TestLogan.zip i sent you.

Please let me know if you need anything else.

Thanks !


Hello uced,

I have downloaded your project. I chose to reopen the items that you had when prompted on opening your project. I do not see what you are seeing. I am linking you a screenshot of your project that is viewed in your skeletal mesh. I did not touch any settings or change anything.

If you would link me a DxDiag I have another theory as to why this is happening.

Thank you,

Hey ,

Interesting ! You’ll find my dxdiag enclosed.


link text

Hi uced -

This looks like something has gotten stuck in your Stored Engine Cache and causing the Asset to render with incorrect shader information in Persona. Go to C:\Users[UserName]\AppData\Local\UnrealEngine\ and delete all of the folders in this folder. This will force the engine to recompile all shaders and information on next upload. This is how I was able to fix an issue similar to this in the past.

Let me know if this does not work for you -

Eric Ketchum

Hi Eric,

It worked perfectly, thanks a lot.



I’m sorry to report that the problem seems still present.

I tried some of the infinity blade new packages, on the left, the frost giant in a new 4.9 project, on the right, the same in my project:

I have emptied the cache directory entirely several times.

When i do so, everything is fine the first time i open a skeletal mesh, but the second time (even if i open a different skeletal mesh from the IB warriors collection), the problem is back.

This happens only with the IB warriors collection, and in case this helps, i have reassigned them the UE4 mannequin skeleton from the anim starter pack.

Do you think any shader corruption could come from a change of skeleton ?




Somehow, the corruption has propagated, now all my skeletal mesh previews are plagued with this problem.

Is kind of annoying because i am using the preview window to take pictures for my UI. So currently, i have to migrate every asset i want to take a picture of in an other project, not a super comfy workflow.

Deleting all the cache solves the problem for a time but i have to redo all my editor conf. Any thing in the cache that i could surgically delete as a workaround ?



Hi uced -

I cannot give you an exact folder to delete since I am not certain what ultimately is causing the issue to re-occur. I am only able to see the effect from your linked project; we have been unable to reproduce the issue outside of your project. Can you let me know anything that you are doing in the Project, I know your on Windows 10 are you running 4.9 in DX12 mode, things like that?

Thank You

Eric Ketchum

Hey Eric,

As i cannot reproduce this outside my project, there must be something specific to that project.

As far as visual options are concerned, i do nothing special (didn’t touch any option as far as i remember).

Regarding skeletal meshes, i torture them as much as possible (several different meshes per skeleton, several different skeletons, retargeting of every anims on every skeleton/mesh, the whole work).

It’s probably worth mentionning that i have installed a beta nvidia driver to take into account the oculus rift dk2 0.7 sdk, but as i can’t reproduce the problem on the same machine in a different project, i guess that’s not it.

One thing i do only in this project is using the allegorithmic substance plugin, so i don’t know in what way this could alter the SM preview window, but that might be a lead for you.

If we can’t point the cause of the problem, is it possible to clean my project as much as possible ?

I tried to clone it (right click in the launcher) but 70% of my content directory was missing in the clone so i abandoned the idea.

Have you any idea of everything i can delete in my project ? (don’t worry about mistakes, i will of course test on a copy) ?


Hi uced -

As a test I would download a version of the engine in which you do not install the Occlus 0.7 runtime and revert temporarily to a non-beta Nvidia driver and see if you can run the project without generating the error. If so, then start adding back in one item at a time.

You would also want to try 4.9.1 just to see if there might be a fix for the issue, I doubt it, but it is worth a try.

As far as what to delete, because you are deleting the DDC from the engine directory there is nothing much I can narrow down as it is generated on an engine level and not just a project level. Also I would point you to shaders which is the most costly building-wise when you first open the engine, but that is most likely where your problem exists, so you would need to delete those anyway.

Thank You

Eric Ketchum

Hey Eric,

I installed 4.9.1, entirely uninstalled the oculus runtime, came back from nvidia beta 355.83 to the current stable 355.82, and emptied again the entire cache.

The problem is still there.

I made some more tests and noticed the following:

  • it is definitely a shader problem: as long as the first shader compilation is not finished, i can open the mesh several time with no problem. As soon a the compilation is over (for a mesh), the problem occurs

  • by trying everything available in the lighting drop list (lit, unlit, wireframe, etc.) it seems that the problem is occuring when i use “detail lighting”, all the other possibilities are ok.

I don’t know if you can deduce anything from that.

I made you a video to make things a bit clearer, it’s silent, 1 min long (about 50 mo), you’ll find it here:


I run three tests:

  • first i show you (using the dragon) that the problem seems to be in “detail lighting”

  • second i open a mesh, then let it compile, and it’s still ok at the end. Then i just close it and reopen it, and it’s corrupted

  • third, i open another mesh, then close it and reopen it several times before the end of the compilation, it’s always ok, until the compilation is over, then it gets corrupted at next reopening.