What does this mean? Not expecting project ... to already have a target rules of with configuration name Game

I’m trying to package the Face AR Sample project for iOS. This project can be found in the Epic Games launcher under the “Learn” tab.

I was able to package it before without problems but today it is no longer working. I tried Removing local content using the Epic Games launcher and downloading the project again. It still doesn’t work. It makes me think some sort of file or setting is being remembered from the deleted project.

Here is the error:

Bulbasaur is the username for my windows PC which is running Unreal Engine.
Sean is the username for the mac that I’m remote building to.

I’m not sure if this helps but I found this on the mac computer:

So I tried deleting the Intermediate folder listed in the error. This folder lived on my macbook which is listed as a remote build server in my Unreal Engine Project Settings. This worked and I can compile again.

If someone has details on why that worked then I would be grateful if you explained.

I also have this error, when trying to generate files but deleting the intermediate didnt fix it, any other ways to fix this?

Having the same issue. Did you fix it?

This is some BS, I’m so angry. Just installed UE5, never done it before and I get this error while trying to create a new empty project. I have no files, no folder, just trying to create an empty project from scratch.

For me it worked after deleting every Unreal Engine related Temp folder at

1 Like