What about Visual Studio 2017 in UE4?

Visual Studio 2017 has been released days ago!
Did somebody know when it will be integrated in UE4?

Hi fsportelli,

Version 4.15 supports both Visual Studio 2015 (default) and Visual Studio 2017. If you are building the Engine from source code, you would want to open a command prompt after running Setup.bat and run the command GenerateProjectFiles.bat -2017. This will give you a Visual Studio 2017 solution for the Engine.

To use Visual Studio 2017 for projects, you can set your preference for which version projects use by going to Edit -> Editor Preferences -> General -> Source Code and choosing Visual Studio 2017 in the Source Code Editor setting.

Tim

Thank you very much!

@Tim Lincoln is there also a way to generate VS 2017 solution files for UE4 projects? Every time time I create a project it shows up as a VS 2015 solution in my Visual Studio.
I have set the source code editor to 2017, but this does not change anything for me.

There does appear to be an issue when making an installed build on a machine that only has 2017 installed.

StripTask.Execute: Stripping symbols: C:\Users\photex\Projects\UnrealEngine\Engine\Binaries\Win64\Android\UE4Editor-Android_ASTCTargetPlatform.pdb -> C:\Users\photex\Projects\UnrealEngine\Saved\Engine\Binaries\Win64\Android\UE4Editor-Android_ASTCTargetPlatform.pdb
Program.Main: ERROR: AutomationTool terminated with exception: ERROR: Failed to start local process for action ("The system cannot find the file specified"): C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\v12.0\AppxPackage\PDBCopy.exe "C:\Users\photex\Projects\UnrealEngine\Engine\Binaries\Win64\Android\UE4Editor-Android_ASTCTargetPlatform.pdb" "C:\Users\photex\Projects\UnrealEngine\Saved\Engine\Binaries\Win64\Android\UE4Editor-Android_ASTCTargetPlatform.pdb" -p
Program.Main: AutomationTool exiting with ExitCode=1 (Error_Unknown)

The pdbcopy.exe is expected to be found in C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\v12.0\AppxPackage\ but if 2017 is the only installed version of Visual Studio then it will actually be found in C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\v14.0\AppxPackage.

If you don’t want to install 2015 (which takes forever) you can just symlink a new v12.0 folder to v14.0 in C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio:

// Run cmd.exe as administrator!
cd C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio
mklink /J v12.0 v14.0

Hi @bcnobel,

I still don’t work primarily in Visual Studio 2017, so I didn’t notice this issue. Thanks for pointing it out. I did some tests and noticed that when you change this setting it appears to only set it for the current project, instead of setting it at the Editor level, which is what I would expect it to do. I have entered UE-44289 to have this investigated further.

Tim

Hi @PortStone,

If you run the Visual Studio Installer, and select the option to Modify your Visual Studio 2017 installation, what options do you currently have selected?

Tim

Hi @invicticide,

This is actually a slightly different issue than what was addressed by the original question. We would like to try to keep posts on AnswerHub on a single topic. I have started looking into the situation that you described, but could you please create a new post for this issue in the Bug Reports section so we can look into it there?

Tim

Hi Tim,

Thanks for the answer.
I already fixed the problem by reinstalling VS and deleted my comment but seems like it didn´t worked sorry.

PortStone

HI @Tim Lincoln,

I compile source code in visual studio 2017.
then, I create a C++ project in Unreal4.
but the game sln is for visual studio 2015 when I open the new game project file.
I can only open the .sln file and no UEditor. so “Edit → Editor Preferences → General → Source Code” cannot find.
Please help, thanks.

FYI, there’s a bug for this already, Unreal Engine Issues and Bug Tracker (UE-51362). Feel free to upvote. :slight_smile:

How would we do this for the 2019 version of VS now?

GenerateProjectFiles.bat -2019