Weird UVs problem with 3dsMax 2015

After editing my UVs in Max, I export the model as a .FBX (Binary, FBX2014), but when I import the mesh in Unreal the UVs are all messed up. I assume this is not UE problem, since I get the same result when I import it back in 3dsMax.
I tried to export it as an .Obj and everything works fine when I import it back in 3dsMax. But what is really weird is that if I export the reimported Obj to UE as an FBX everything works! (I’m of course using the same FBX export settings). Any idea why this is happening?

By default UE4 will generate new lightmap UV’s, if you have lightmap UV’s already, make sure to disable that option in the Import window.

That didn’t solve the problem.
One thing I didn’t mention is that my UVs are multi-tile, they don’t lay just in 0-1 space (like this). It was not a problem in UDK, maybe it is in UE4.

It shouldn’t matter if it goes beyond the 1x1 space
It could be an issue with the FBX version

How’s your modifier stack? Are you collapsing it before you’re exporting?

I would also slap a resetxform on your object. Just make sure it’s nice and clean before exporting.

I read that somewhere when I was looking for a solution, I tried to change the FBX version but I still get the issue.

Collapsed to Editable Poly

Already Tried

I am using 3ds Max 2012, with FBX version 2013, the version it’s exporting as is FBX 2012 as Binary.

I had problems with that too.
What works for me: After I create the mesh geometry as desired, I collapse the stack to editable poly. Then I add two UVWUnwrap modifiers (one for texture channel and one for lightmap). After making the layout in the UV editor, I export the object with the stack holding the two unwrap modifiers.

Ok, I tried, it didn’t work. This thing is driving me mad.

This is my UV layout for another mesh:

And this is the result in UE:

The UVs are exported fine (it seems). The same thing happens if I import that FBX back in 3ds Max: the UVs seem to be fine, but if I use CheckerPattern I can see that the mapping is all screwed up

Ok, I converted to Editable Mesh and the model is fine now… Why??? I always used Editable Poly and never had any problems with it

I see one potential problem in your screenshot…

The mesh stats say: 1 UV channel, and you havent ticked the “generate lightmap uv” option. S currently UE4 uses this overlapping! uv set for both.
I see the two unwrap modifiers in your stack. Did you c hange the channel of the second one? If not, it just continues to modify the uv map in channel 1 (which becomes channel 0 in UE4)
Are you sure the mesh preview shows the side with the “proper” UV island…

I made this video a while ago to explain it to someone… Might be helpful :slight_smile:

I’m aware of the fact that a second channel is required to store lightmaps informations, but this data is only computed on lighting rebuilding and it shouldn’t make any difference in the “preview window”, should it? That also doesn’t explain why converting the model to Editable Mesh rather than Editable Poly seems to solve the problem.
However I already tried creating a second channel in 3ds Max or ticking “generate lightmap uv”, but the problem persisted. (The overlapping is wanted for texturing purpose)

I know what you are going thru, using Max 2015 SP3 I couldn’t get my multiple UVW channels to stick either, was also using editable poly. I would flatten/position channel 1, collapse stack and add another UVWUnwrap mod for the 2nd channel, rinse/repeat. It refused to save the 2nd channel, I even went to the Autodesk forums to make sure I was doing it correctly (maybe I was missing something new). Even after a mod at Autodesk explained the exact same process I was doing, it still didn’t work!

What worked for me finally was, instead of collapsing the stack, I stayed in the editor and positioned all of the channels at once, then collapsed… it worked. It was extremely frustrating and it shouldn’t have been. After reading your post about this, it has to be a bug. I have Max 2016 now, so I’ll have to test to see if it still does this. I’ll try editable mesh option also.

I dont want to open new thread, but can anyone helps me with this situation? After switching to second uv channel, texture is weird and dont works on my uv map.
Here is my thread

Because then you have control on how the triangulation is made. If you export it as Poly, the engine will trianguate the mesh on import which can lead to unexpected results.

Problem was because I forget change UV channel in material editor :smiley:

Now it works perfect!

3ds ax 2016

Hey ! Ive had this problem on and off in the past and never found a solid solution to solve this. just luck and repeating simple actions like reset xform etc
Have you used 3ds max 2016 long enough to say that the problem has been fixed ? Would going down to 3ds max 2014 be worth it for the time being ?

Ok I was having the same issue as well. Using 3DS Max 2016. Was getting uv channels broken, being deleted, replaced, etc. I tried everything you guys have listed on the forums and it turns out switching the export options from binary to ascii helped.b3e65e27bf5c886e1ca99d05950fafdc7d4bc244.jpeg