Download

Weird Up axis importing issue

So i’ve been trying to get some meshes inside UE4 and i get a weird issue that i think is related to the Up axis orientation.

I’m exporting from max 2015 using FBX 2013 with the Y up option, but my meshes receive correct lighting only when rotated 90 degress on the Y axis in UE.

http://fc07.deviantart.net/fs71/f/2014/196/e/9/untitled_1_by_nitroxart-d7qr2n9.jpg

You can see the mesh without any material applied receive correct lighting. If i apply the material it gets shaded correctly only if i rotate it 90 degrees on the Y axis.

I’ve also checked for a flipped green channel on the normal map and it kind of weireded me out that nothing changed between the 2 : /

Hi Fnitrox,

I’ve set up a scene similar to yours but have not been able to reproduce the results you’re getting.

I made a similar 5 plank mesh in 3Ds Max and exported that. I created a simple material using the Pine Texture and Normal in the starter content.

As you can see in the image I’ve not been able to have the issue.

I may need a little more information as well to see what’s going on. I also think something may be linked to your texture that is causing the issue since the mesh is not showing issues without the texture when laying flat.

How is your material setup? Can you post an image of the material graph?

Also, does it do the same with other materials, particularly any that are included with the Starter Content? If not, we can rule out this being something with the mesh.

If you break the link for the normal map on your material does it give the same results?

Also, if you want me to personally take a look at it you can link a download to your asset here with the texture or if you don’t want it to be public you can send me a private message with the download link.

Let me know what’s going on and I’ll look into this more! :slight_smile:

Tim

I thought it was supposed to be Z-Up for imported meshes? Have you tried that?

Thank you both for your replies

@DotCam: I have since tried with both Z and Y up, and nothing changed.

@Tim Hobson: The material was just a simple 3 textures samples, Diffuse Mormal and one for Roughness/Metalness/Occlusion, I’ve unplugged everything but the diffuse and normal too see if it was any problem it. Now i’ve unplugged the normal too and its shading correctly so i guess it was a normal map issue after all.

I’ve uploaded the FBX and the 3 textures on my google drive if you want to investigate further. ZIP Archive LINK

The material is nothing fancy as i just made it to test the textures in engine. You can find it here (note some stuff is unplugged as i didn’t want to wait to recompile :D)

Thank you for your time :slight_smile:

Yeah definitely the Normal map here. How did you create the Normal?

Thanks!

Tim

It was baked in xnormal with a cage.

In toolbag 2 it looks fine tho… i’ll double check it

Ok after rebaking all the textures i still couldn’t figure out what caused the error.

So this morning I just deleted the project and started again from scratch. Remade the simple material and reimported a mesh with its 3 maps.
I first didn’t include the roughness/metal/ao map in the material so there was just the diffuse and normal input. The error was nowhere to be seen.

So i added the 3rd map in the material and plugged it. The error came back. Now comes the part where i’m ashamed of myself and how retarded i’ve got to be for this.

I had plugged the map with roughness etc in the normal map slot, because it was the second in the list, but that list is ordered alfabetically and not as in the material editor…