Weird Unreal Engine 4.11 - 4.2 Crashes. Probably due to memory problems

I’m experiencing constant UE crashes lately. The Editor crashes A LOT (~10 times a day or more) and at first I was thinking those crashes were totally random, they could happen at any time I press any button. But then I started to notice that most of the crashes happen when something is loading. Most of the crashes happen when I press the Compile button especially if I do it quickly after changing something in the blueprit (I start so hear the usual hard drive sound and then Editor crashes). Sometimes the crashes happen when I open new window, like physics asset window or switch from Body Mode to Constraint Mode in physics asset.

I wonder if this is something in the UE4 or is it my HDD just dying… Its old, something like 5 years old, but I havent noticed any problems with it previously in any app. And the “working sound” isn’t something scary, just the usual HDD sound.

Anyone having similar problems?

Win 10 x64, 8Gb RAM, GTX 580, i7 920. UE 4.12 Preview 5

Hey rocketman-

Can you provide your machine ID to help us investigate the crashes? Can you identify exactly what is causing some of the crashes? Ex: if it crashes while compiling a blueprint, can you provide details about the blueprint and if that specific blueprint crashes each time you compile? Any additional info you can provide about the crashes you’re receiving will help us investigate.

link text

All the blueprints. I’m using ThirdCharacter Template project as my base. It crashed in the character blueprint, in animation blueprint, in tutorial blueprint. I tried creating new Third Person Template projects in 4.11.2 and in 4.12 Preview 4, and in 4.12 Preview 5. Most of the time it crashes in character bp (probably because I work in it most of the time). And one thing I have noticed is that if I press Compile JUST AFTER I changed something in the blueprint like added a getter to the graph or connected a variable it crashes really often (I start to hear HDD sound for a second and then the crash happens); but if I change something in the blueprint and wait for a few seconds — crashes still happen from time to time but a lot less often. In general it feels like if due to my actions in Editor the hangs for a second — there almost definitely will be a crash, but if I avoid doing everything quickly so it has time to process — still crashes but less often.

Not sure what you mean by machine ID, so I attached DxDiag.txt

When the crash occurs it should present you with the black, crash report window. In the window it should list your machine ID at the top before the callstack. Please take a screenshot of this window so that we can see the machine id as well as the callstack presented. When the crash occurs, please also indicate what you were doing when it crashed as well as supply the project’s logs from the crash. The logs can be found in the project’s Saved/Logs folder after the crash occurs.

[link text][2]

I was editing the text in the tutorial blueprint. The blueprint was a copy of the default ThirdPerson Template tutorial blueprint, I have several edited copies of this tutorial in the folders. Is it okay to copy the tutorial blueprint and then edit it, or should I create a new one from scratch every time?

I just created I new tutorial blueprint from scratch and tried to edit it, and the UE crashed. I didn’t even press compile button, it crashed when I was typing.

Hey rocketman-

I’m finding a number of crashes related to an array out of bounds error. If you are seeing this crash in multiple projects, can you provide the exact steps to reproduce the problem (from project creation until the crash occurs). If it is only crashing in one project, please provide a copy of that project for me to test directly.

Where should I send you a download link? (not here)

If you can upload the project to Dropbox or GoogleDrive you can send me a private message on the forums with the download link.

Sent you a message on forums

I received the project you sent however I have not had a crash occur when creating/opening/closing/compiling blueprints or when playing in the game. Can you confirm that you’re still getting the crash on the the release version of 4.12? If you do get a crash, please indicate exactly what you were doing at the time (which blueprints you had open, what you were doing in the blueprint).

Release version seems to work.