Download

Weird stuff happening to my screen when launching unreal engine

I have recently got a new laptop, I transfered all my files to the new laptop but now when I launch a project it disorts my screen temporarily from time to time as shown in the picture.This issue is temporarily fixed by changing tabs and then going back. However, sometimes it will cause pixels to distort/blurr on my screen; which requires a restart.
Is anyone able to help me fix the problem?

Thank you for your time

Laptops often throttle performance under many circumstances which can cause graphical bugs, if you have a laptop with an Intel processor along with a dedicated GPU (like Nvidia) you’d need to make sure that it is set to only use the dedicated GPU and not the integrated Intel GPU to get the best performance in UE4. You can set that in the Nvidia Control Panel under the 3D settings to use the Nvidia GPU as the global default. Also make sure you’re using the laptop plugged in or go into the power settings and set things to Performance.

Thank you for your response.
The Nvidia Control Panel was already set to use the dedicated gpu as global settings and even after changing the settings to performance (in Nvidia and battery settings) the graphical bug still appears. I tried setting UE4 specifically to use the dedicated GPU as well and my laptop plugged in. Even then the bug still happens.
When the bug happens I notice in Task Manager that under GPU engine it usually switches from gpu 1 to gpu 0 and vise versa when the bug happens.
For reference I’m using an rtx 3060 and a i7-11800H with 16gb ram.

I have also discovered that when I disable my integrated graphics card’s driver it doesn’t crash (at least not that I have seen) but unreal engine starts running extremely slowly.

Yeah, so the issue was that it was still trying to use the integrated GPU for some reason. Changing the global setting in the Nvidia Control panel should have done that, but you can do like you did and disable the Intel GPU as well

Well like I said it seems to fix the bug. However, it starts running extremely slowly so that doesn’t seem like a plausible fix. (If I turn the integrated driver off I get about 4 fps in unreal; I also tried running unreal with only the integrated driver and it runs even slower, so I don’t really know what it’s doing). Do you know of another fix, or is it possible that some reset of unreal engine will fix this?

Sometimes it crashes now, so I looked into the log and it has this error: [ 39]LogWindows: Error: Error reentered: Fatal error: [File:D:/Build/++UE4/Sync/Engine/Source/Runtime/D3D12RHI/Private/D3D12Util.cpp] [Line: 684]
pResource->Map(Subresource, pReadRange, reinterpret_cast<void**>(&pData)) failed
at D:\Build++UE4\Sync\Engine\Source\Runtime\D3D12RHI\Private\D3D12RHIPrivate.h:1181
with error DXGI_ERROR_DEVICE_REMOVED with Reason: 887A002B
I don’t know if it’s relevant or not to the error but I don’t have a D drive.

What are your system specs?

I have a core i7- 11800H, GeForce RTX 3060 and 16 gb ram. My laptop is running on windows 10.

I tried to reinstall my graphics driver as I saw that that could work. Sadly it didn’t work.

Update: I tried different versions of unreal engine. Nothing seems to happen with “the old launcher” as in I tested unreal engine 4.22.3 and it seems to work fine. Any version after that has the glitch and crash.

Maybe waiting for UE5 and hoping the internals are sorted or maybe even remade with fixes. Sad that you need an older version. I used to be happy with Unity 2018 when 2020 was out. UE5 isn’t long coming. I would like for UE5 to work fully for you.

Nowhere have you stated that you checked the invidia drivers installed are the latest - so you should probably do that first.

Don’t wait on ue5 - it’s only just been worse than 4 so far performance wise.

For the driver I downloaded it directly from Nvidia’s website a couple of days ago so I’m assuming it is the lastest one.

I guess I’ll have to use the previous version of unreal for the moment being. Hopefully there will be a fix soon… I might try doing a clean reinstall of unreal engine soon and see if that fixes anything.
Thank you for the advice given so far.

@RoVd14

Instead of rebooting, try windows shift B or whatever the key combo is to refresh/restart the graphics driver.

If the problem goes away, the issue is the physical card, or the driver.

If it remains as is, then the issue is being actively caused by the program… (But then it would go away when you quit unreal and reset the driver, technically).