Download

Weird Skeletal Mesh and Physics Asset

Hello! I’m not the greatest when it comes to using the new blender interface and exporting to unreal so bear with me.I made a character with animations.I exported it in unreal and I found 2 problems. 1 the collision capsules look like… that.(picture 1) and the skeletal mesh bones are in the wrong positions(picture 2) any idea how to fix these problems, explained as noob friendly as possible? Thank you alot! Have a great day!

This is amazing, I would love to learn how to do this soon.

  1. thats normal by default. Delete everything and make the phat asset by hand.

  2. you really need to use the epic skeleton if you want any sort of compatibility.

The position of the bones don’t really matter. Coming from blender the tail end is ignored, while the root is the start of where the bone is placed in UE.
the next patentepatent’s root is where the bone will end.

As such, it would seem that your blender bones are flipped backwards.

To avoid problems you can tilt the bones horizontally after separating them all so that they are never visually connected.
This prevents you from thinking everything is fine and forces you to think on how they actually work in engine…
importong the default mannequin does that for you. You just learn to get used to how it works/looks over time.

could you please explain what exactly do you mean by flipped backwards if you don’t mind? I’m not that clever…

Also I managed to get this by setting the min bone size to 0:

when I try to simulate physics this happens to the legs, any idea what’s the problem there? :

Thank you alot!

As in the tail is where the root should be and viceversa.
A screenshot of your skeleton in blender would help diagnosing that.

Re the phat asset legs.
you have to manually set up the constraints. The bodies aren’t the only things needed for it to work.
you should check the official videos on how to set up the phat asset for ragdolling.

this is the skeleton in blender

The bones in blender look ok. Try disconnecting them and see what the import does.

Turns out that you were right, that’s just how unreal shows the bones.The physics assets I’ll spend a while to try to make them look as good as possible,thank you alot!