Download

Weird shadows on foliage

I am using some bamboos from Bamboo Valley and I am getting some weird shadows. I have tried foliage instance and placing single static meshes as ell but both are giving me the same problem while the same mesh is fine in the Bamboo Valley project. I haven’t changed any setting under static mesh editor.

Two images at the top are from Bottom Valley while the bottom 2 are from my project.

Any ideas why it is happening?
I am using UE 4.26 with GPULightmass, static skylight with HDRI, movable sun and static mesh for bamboos

Do you use ray tracing? Meshes with vertex shaders which let the mesh move from wind need a tick box to be activate called ‘evaluate world position’ to work proper.

I don’t know of any way to make that work for foliage actors. The only other way would be to disconnect the world position offset in the material of the bamboo.

Not sure if that’s causing the problem but you could give it a try.

Thanks for your reply.
I am using raytracing but the sun is not casting raytraced shadows. I already disabled it.
Also, Raytracing is only enabled for reflections and nothing else.

It’s strange that it isn’t working by default as it’s working in the “BambooValley” but not in my project. Anyways, I just tried your method of ticking the “Evaluate World Position Offset” parameter and did a test but the issue is still there.
Check the below image.

I also tried your other method by disconnecting the “World Position Offset” node in the material but still have the problem.
Check the below image for that.