Weird reverb issues

Hi, Unreal people,

I just installed a 4.22.3 hotfix and a weird thing happened to all my reverbs. The send levels for all of them through all game dropped drastically, they are hardly audible now. I checked with a previous 4.20 version of the game and reverbs are there - well audible in the mix, on proper levels.

I checked all the settings regarding audio volumes, reverbs themselves, sound attenuations and project settings. Everything should work fine, but it simply doesnt.



1 Like

Maybe you enabled new audio engine(it has better reverb etc) at the engine level, on 4.22.2? That config file change would be reverted after upgrading to 4.22.3 via launcher…

Nope, I got that fixed too. It’s realted to attenuation reverb send param, which wasn’t present and now is. This is also not version related - we have two computers dedicated to this game production in the studio, both running UE 4.22.3. The one that got latest project update via P4V has this new param available. The one that didn’t get latest revision - no attenuation reverb send param in attenuation settings.

Nope, new engine working for quite some time now, utilizing its. possibilities since 4.20 when the game project was born.

Anyway, seems that we have the basic source of the problem located somehow. The prog team enabled a tool for lipsyncing NPCs to the wave amplitude, reverb distance-based sends appeared somehow on the way. I need to go through the game and set the reverb levels manually, sound per sound. I used some basic sound attenuations to start with, but most of the game (more than 80%) is mixed manually, sound by sound, cue by cue, according to particular needs.

The game was actually already mixed, now not only the reverb is gone, but occlusions and distance attenuations sound different, too, the game got too loud and messy.

Way over 100 hrs spent on mixing this game to the top notch level. Distance based reverb sends? Great, I don’t need them for this game though. Probably need to mix the game again, sound by sound, cue per cue. Frustrating as ■■■■, yet must be done. Nobody’s fault actually, ■■■■ happens, yet I hope that the game’s producer remembers my words from january that it would be really best option to mix the game as the last stage of work, not trying to do it “on the way” when lots of game design, mechanics, objects, scales change all the time, needing new mixing decisions every day. And it may always happen that one f*kked up update of the engine or function enabling may ruin the work on this field.

And there it is.

If anybody experienced anything like that, let mie know. If anybody has a solution to this, like reverting to previous state without having attenuation reverb sends enabled - LET ME KNOW.


Hi @Leveuho, sounds like a serious hassle!

Just to be clear, are you saying that the NPC Lipsync is interfering with the Reverb Send amount?

Or are you saying that the team upgraded to 4.20 and that Reverb Sends were part of the upgrade?

Because distance-based reverb send amounts were part of the Sound Attenuation structure in the Audio Mixer from 4.15–it was one of the AudioMixer’s launch features and Aaron and I demonstrated it in our February 2017 Livestream announcement of the new Unreal Audio Engine. So that should not have changed.

If you need to mass edit data properties, you might want to check out the Property Matrix Editor which is available in the Asset Actions context menu. You can edit values on multiple assets at the same time then and it’s a life-saver when tons of properties have to be changed the same way.

Hi Dan, so good to hear from you! I’ll investigate more in an upcoming week, but the data I collected remotely from the programming team sums up to this:

  • NPC lipsync turned on,
  • attenuation reverb send on and visible in attenuation settings - i never utilised it before and never needed it for this particular game,
  • general reverb send levels went totally, totally down and need reworking via bulk edit/matrix + more manual work for sounds being sew into blueprints,
  • all operation happened on 4.22.3, we ported the project from 4.20 with no hassle at all few months ago,
  • the sound mix of the game fell somehow apart - things are louder in general, less separable, don’t seem to react properly to distance change and occlusion settings,
  • I’ll tell you more when I investigate more, talk to the programmers and dig into sound content, with a fresh pair of ears next week, thanks for your help a lot anyway, let’s keep in touch, your assistance might be invaluable here!

And one more question, Dan - is it possible that the new audio engine was running with no attenuation reverb send, yet with most new engine functionalities?

how do I check that?

where do you set the reverb levels manually?


I have a similar problem with reverb after upgrading a project from 4.22 to 4.24. In the video below after 10 seconds you hear the reverb is like noisy after upgrading.

Steps to reproduce:

  • Login to epic games launcher :wink:
  • Make a project on 4.22
  • Make new level with audio volume and large hall reverb preset
  • Make Audio Cue from some sound (my puck sound could be found here:…ew?usp=sharing
  • It should sound like in the first 10s of my video

–> upgrade the project directly to 4.24. I know its better practice to first upgrade to 4.23 and then 4.24, but recently for everything else but this reverb effects things just worked without going inbetween

Listen after upgrade and it should sound like after 10s in my video.

I checked all the sound classes like master class and whatnot but really cant find out what is causing this and I wont spend anymore time on this. Dont know how to solve this without external reverb plugin anyway now.

I kinda can make this reverb sound in 4.24 with google’s spatial/reverb plugin, but no idea how I would fix it without it.