Weird rendering problem

It happens only from a certain distance, and as long as i getting more far away it escalates exponentially.

This is just a bunch of blueprints that has a cube mesh in it.
This is how the mesh looks like:

This game is an editor that allows you to build levels like minecraft, so this is why it has to be composed of multiple cubes.
I know the horizontal lines can be fixed with playing with the shadows settings, but what about all that weird artifacts?

Hi ,

I’ve tried recreating the issues you’re reporting but have not had any luck. While I’m using the editor cube from the modes > Basic > Cube panel with an applied material. I’ve also not set this mesh in a blueprint either.

By looking at the horizontal lines that are present it would appear to be an artifact of adjusting the shadow bias or cascaded shadow maps in your directional light source. I see you mention that you can get rid of that issue, but not the triangles that are appearing.

Would you be willing to share how you’ve setup the BP so I can recreate on my end? Also, can you try switching the mesh out for one of the cubes in the starter content or the engine folder to see if this resolves the issue? We can rule out some things that way. Also doing a test to see if a meshes placed in the editor that are not in a blueprint could resolve the issue, again, depending on how things are setup.

Let me know.

My computer have problems so it took a while for me to answer, this is a picture of an other computer with clean install of unreal engine 4.7.3, using the base cube that comes with the engine with no blueprint :

As you can see, the problem is a lot less noticeable, but still there.
You need to fly far enough from the cubes and then you will try to see these little artifacts.

I just want it to look like a seamless floor.

More info:
I’ve loaded the project into the computer i’m working on right now.
As far as you get from the cubes the issue is escalating.

This is how the blueprint’s components view looks like:

Also tried it with some basic cube mesh that came with one of the project’s examples and still the same results:

All the tests above was tried in Epic quality and lowest quality with no shadows or any other effect.

More updates !
I’ve replaced all the blueprints with the most basic static mesh cube that comes with the engine.
as you can see from one of my previews comments on this thread, you can barely see the artifacts, however, they are still there.
Also notice i’v used the default scale of the cube.
Now i’v noticed that the bigger the mesh the bigger the artifacts.


built in engine cube scale 1:

built in engine cube scale 5:

built in engine cube scale 20:

This is probably because i can see the cubes even when i’m farther away from them.

You can even see the previews smaller cube groups in the background on the third image ( scale 20 ) and how full of artifacts they are.

It seems like as long as you getting more far away from objects the accuracy of the shape of them is lowering.

This happens in 2 different computers and i’m sure this is something with the engine. is there a way to increase that distance so the objects will remain accurate from farther distances as well ?

Hi Sahkan,

I’ve still not been able to reproduce this issue on my end.

I’ve setup several rows of the basic cube and even scaled them as you’ve indicated from your test.

Here are my results:

Would you be willing to share a blank project this can be replicated in? If you only use the basic cube (with plane white material) from the modes panel in the top left you can just attach a map and I can see if I can see the same results. A project would be better if you can replicate because then I can see if it’s something in there.

It’d also be good to know what your lighting settings are set to, your world settings, and anything that is not set to default. All of my settings are default and I’m not able to replicate. Even adjusting the settings to see if something randomly appears has not worked.

Let me know.

Ok i’v deleted the config folder so unreal will remake it in the default form, and it fixed the problem, and now i feel stupid :X
I guess this thread will be useful for anyone who has that problem at least.
Thanks for the help Hobson and i’m sorry for wasting your time lol :stuck_out_tongue:

So Glad I found this thread, I’ve been having this problem with weird lines appearing at distance on meshes moving and rotating as you move though the environment. I been messing with all the setting and couldn’t figure it out. I deleted the Config folder and it fixed it. Thank You !!!